Tutorials Vyatta Case Study 3 Cisco 3750 L3 Config
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3750-Cisco
!
enable secret 5 $1$s5f/$sRFblU7QRgnKBuA1ZqyX51
!
no aaa new-model
switch 1 provision ws-c3750-24ts
ip subnet-zero
ip routing
ip domain-name domain.net
!
ip multicast-routing distributed
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback1
ip address 10.200.1.3 255.255.255.255
!
interface FastEthernet1/0/1
description Vyatta_A
!
interface FastEthernet1/0/2
description Vyatta_B
switchport access vlan 2
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/4
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
switchport access vlan 2
!
interface Vlan1
ip address 10.100.1.1 255.255.255.0
!
interface Vlan2
ip address 10.100.2.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
area 1 stub
network 10.100.1.0 0.0.0.255 area 1
network 10.100.2.0 0.0.0.255 area 1
network 10.200.1.3 0.0.0.0 area 1
!
ip classless
ip http server
ip http secure-server
!
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
snmp-server location Russia
snmp-server contact Wladimir
!
control-plane
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
ntp clock-period 36027358
ntp server 10.1.2.2
end