TOTAL
Depuis Dec 2006
1'942'871 Visiteurs
4'218'042 Pages

Stats Nov 2010
82'909 Visiteurs
146'476 Pages
196 pays
Statistiques completes



Aidez-nous à traduire
nos tutoriaux!

REJOINGNEZ
l'équipe OpenManiak.
QUAGGA - Le Tutorial Facile - Etude 1 - Routage statique

Quagga Etude 1 - Routage st.
Dernière modif: Dec 06 2007


Tool
Installation
Ergonomie
Forum



Détails Quagga, c'est quoi?
Prérequis & Installation
Comment utiliser Quagga
Comparaison des fonctionnalités de routeurs
Étude de cas 1 - routes statiques
Étude de cas 2 - OSPF simple
Étude de cas 3 - OSPF avancé
Étude de cas 4 - BGP



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. PRINCIPE 2. SCHÉMA 3. CONFIGURATIONS 4. COMMANDES SHOW
Voir un scénario similaire avec le routeur Vyatta.


1. PRINCIPE

Dans cette première étude, nous allons voir un exemple très simple où le routage est fait par des routes statiques uniquement.


2. SCHÉMA

quagga cisco 2651 3750 static routing Fonctionnalités testées:

Paramétrage interfaces
Routes statiques
Accès Telnet

 
 
   
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

Vous devez configurer votre système Linux correctement pour pouvoir lancer Quagga avec succès.
Référez-vous au tutorial Quagga pour de l'assistance.
CONFIGURATIONS LINUX

Vérifiez que le démon zebra est activé sur Quagga A et Quagga B:

#vim /etc/quagga/daemons
zebra=yes
bgpd=no
ospfd=no
ospf6d=no
ripd=no
ripngd=no
isisd=no


Si vous avez effectués des changements dans vos fichiers daemon sur , redémarrez le service quagga:

#vim /etc/init.d/quagga restart
Stopping Quagga daemons (prio:0): ospfd zebra (bgpd) (ripd) (ripngd) (ospf6= d) (isisd).
Removing all routes made by zebra.
Nothing to flush.
Loading capability module if not yet done.
Starting Quagga daemons (prio:10): zebra.


Configurez le nom d'hôte (hostname) de Quagga A dans le fichier /etc/quagga/vtysh.conf:

#vim /etc/quagga/vtysh.conf
!
! Sample
!
! service integrated-vtysh-config
hostname Quagga_A
username root nopassword
!


Configurez le nom d'hôte (hostname) de Quagga B dans le fichier /etc/quagga/vtysh.conf:

#vim /etc/quagga/vtysh.conf
!
! Sample
!
! service integrated-vtysh-config
hostname Quagga_B
username root nopassword
!


N'oubliez pas d'activer la redirection IP (IP forwarding) sur le routeur Quagga A!
Il n'est pas nécessaire d'activer la redirection IP sur le routeur Quagga B parce qu'il n'a qu'une interface réseau.

CONFIGURATIONS DES ROUTEURS

ROUTEUR CISCO 2651 IOS: 12.2-23a ROUTEUR QUAGGA A 0.99.6
interface FastEthernet0/1
  ip address 10.1.3.2 255.255.255.0
  no shutdown
interface eth0
  ip address 10.1.3.1/24
  link-detect
interface FastEthernet0/0
  ip address 10.1.4.2 255.255.255.0
  no shutdown
interface eth1
  ip address 10.1.1.1/24
  link-detect
hostname Cisco-2651
ip route 10.1.0.0 255.255.0.0 10.1.3.1
ip route 10.200.1.4 255.255.255.255 10.1.4.1
ip route 10.200.1.1 255.255.255.255 10.1.3.1
ip route 10.1.0.0/16 10.1.3.2
ip route 10.200.1.4/32 10.1.3.2
ip route 10.200.1.1/32 10.1.1.2
line vty 0 4
  no login
line vty
  no login
enable secret password enable password password

SWITCH CISCO L3 3750
IOS: 12.2-25.SEE2

ROUTEUR QUAGGA B
0.99.6
interface vlan 1
  ip address 10.1.1.2 255.255.255.0
  no shutdown
interface eth0
  ip address 10.1.4.1/24
  link-detect
interface Loopback 1
  ip address 10.200.1.1 255.255.255.255
 
interface lo
  ip address 10.200.1.4/32
  link-detect
hostname 3750_L3 hostname quagga-router-b
ip route 0.0.0.0 0.0.0.0 10.1.1.1 ip route 0.0.0.0/0 10.1.4.2
line vty 0 4
  no login
line vty 0 4
  no login
enable secret password
 
enable password password
 
ip routing
ip multicast-routing distributed
VOIR LA CONFIGURATION COMPLÈTE DES ÉQUIPEMENTS:

Quagga A
Quagga B
Cisco 2651
Cisco 3750 L3



4. COMMANDES SHOW

TABLE DE ROUTAGE

Quagga_A#show ip route

Codes:   K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    I - ISIS, B - BGP, > - selected route, * - FIB route
   
C>* 127.0.0.0/8 is directly connected, lo
C>* 10.1.3.0/24 is directly connected, eth0
C>* 10.1.1.0/24 is directly connected, eth1
S>* 10.1.0.0/16 [1/0] via 10.1.3.2, eth0
S>* 10.200.1.4/32 [1/0] via 10.1.3.2, eth0
S>* 10.200.1.1/32 [1/0] via 10.1.1.2, eth1
Quagga_A (Linux level)#route -n

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.1.4.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 10.1.4.2 0.0.0.0 UG 0 0 0 eth0
Cisco-2651#show ip route

Codes:   C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route
       
Gateway of last resort is not set
       
  10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
C     10.1.3.0/24 is directly connected, FastEthernet0/1
S     10.1.0.0/16 [1/0] via 10.1.3.1
C     10.1.4.0/24 is directly connected, FastEthernet0/0
S     10.200.1.1/32 [1/0] via 10.1.3.1
S     10.200.1.4/32 [1/0] via 10.1.4.1
Quagga_B#show ip route

Codes:   K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    I - ISIS, B - BGP, > - selected route, * - FIB route
   
C>* 10.200.1.4/32 is directly connected, lo
C>* 127.0.0.0/8 is directly connected, lo
C>* 10.1.4.0/24 is directly connected, eth0
S>* 0.0.0.0/0 [1/0] via 10.1.4.2, eth0
Quagga_B (Linux level)#route -n

Kernel IP routing table
Destination Gateway Genmask Indic Metric Ref Use Iface
10.200.1.1 10.1.1.2 255.255.255.255 UGH 0 0 0 eth1
10.200.1.4 10.1.3.2 255.255.255.255 UGH 0 0 0 eth0
10.1.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
10.1.3.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
10.1.0.0 10.1.3.2 255.255.0.0 UG 0 0 0 eth0
3750_L3#show ip route

Codes:   C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route
       
Gateway of last resort is 10.1.1.1 to network 0.0.0.0
       
  10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C     10.1.1.0/24 is directly connected, Vlan1
C     10.200.1.1/32 is directly connected, Loopback1
S* 0.0.0.0/0 [1/0] via 10.1.1.1

INTERFACES

Quagga_A#show interface eth0

Interface eth0 is up, line protocol detection is disabled
  index 3 metric 1 mtu 1500
  flags: <UP,BROADCAST,RUNNING,MULTICAST>
  HWaddr: 00:02:11:22:33:44
  inet 10.1.3.1/24 broadcast 10.1.3.255
  inet6 fe80::201:66ff:1122:3344/64
    46 input packets (0 multicast), 5838 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    251 output packets, 45451 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
Cisco-2651#show interface FastEthernet 0/0

FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0011.2211.3345 (bia 0011.2211.3345)
  Internet address is 10.1.4.2/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:01:20, output 00:00:09, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
    477 packets input, 46396 bytes
    Received 303 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    603 packets output, 58014 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out

VERSIONS DES LOGICIELS

Quagga_A#show version

Quagga 0.99.6 ().
Copyright 1996-2005 Kunihiro Ishiguro, et al.
Cisco-2651#show version

Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(23a), RELEASE
SOFTWARE (fc2)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 30-Mar-04 15:04 by kellmill
Image text-base: 0x8000808C, data-base: 0x81118FD4
 
ROM: System Bootstrap, Version 12.2(6r), RELEASE SOFTWARE (fc1)
 
Cisco-2651 uptime is 1 hour, 21 minutes
System returned to ROM by reload
System image file is "flash:c2600-is-mz.122-23a.bin"
 
cisco 2651 (MPC860) processor (revision 0x00) with 60416K/5120K bytes of
memory.
Processor board ID JAD063356E5 (335158987)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
2 FastEthernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
 
Configuration register is 0x2102

PROCESSES DES DÉMONS QUAGGA

Quagga_A (Linux level)#ps -ef | grep quagga

UID PID PPID C STIME TTY TIME CMD
quagga 10525 1 0 11:36 ? 00:00:00 /usr/lib/quagga/zebra --daemon

REDIRECTION IP LINUX (IP FORWARDING)

Quagga_A#show ip forwarding

IP forwarding is on
Voir des explications sur la redirection IP sous Linux (IP forwarding).

Quagga_B#show ip forwarding

IP forwarding is off
Haut de la page