TOTAL
Depuis Dec 2006
1'942'871 Visiteurs
4'218'042 Pages

Stats Nov 2010
82'909 Visiteurs
146'476 Pages
196 pays
Statistiques completes



Aidez-nous à traduire
nos tutoriaux!

REJOINGNEZ
l'équipe OpenManiak.
QUAGGA - Le Tutorial Facile - Etude 3 - OPSF Advancé

Quagga Etude 3 - OPSF Av.
Dernière modif: Dec 06 2007


Tool
Installation
Ergonomie
Forum



Détails Quagga, c'est quoi?
Prérequis & Installation
Comment utiliser Quagga
Comparaison des fonctionnalités de routeurs
Étude de cas 1 - routes statiques
Étude de cas 2 - OSPF simple
Étude de cas 3 - OSPF avancé
Étude de cas 4 - BGP



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. PRINCIPE 2. SCHÉMA 3. CONFIGURATIONS 4. COMMANDES SHOW
Voir un scénario similaire avec le routeur Vyatta.


1. PRINCIPE

Nous allons tester dans cet troisième exemple un environement d'un niveau de difficuté moyen où deux routeurs (Cisco 3750 & Quagga B) sont reliés entre eux par deux aires OSPF dont une est de type stub (stub area).

Le routeur Quagga B et le routeur Cisco 2651 sont localisés dans une aire de type stub, ils ont des routes OSPF intra (O) et inter-aires (OIA) dans leur table de routage mais aucune route OSPF de type externe.
Pour atteindre, depuis les deux routers mentionnés ci-dessus des réseaux OSPF externes comme 10.200.1.1 dans notre étude, il y a une route OSPF par défaut vers le "border router" (routeur vyatta A).
Quagga A est appelé "border router" (routeur frontière) parce qu'il est à la fois dans l'aire 1 et l'aire 0 (backbone area).

Dans le cadre de notre étude, la route statique 10.200.1.1 est redistribuée dans OSPF au niveau du routeur Vyatta A pour créer "artificiellement" un réseau OSPF externe (OE2). A cause de l'aire stub, ce réseau ne doit pas se diffuser dans les tables de routages du router Vyatta B et du routeur Cisco 2651.


2. SCHÉMA

quagga cisco case study opsf advanced 3750 2651 Fonctionnalités testées:

(cliquez sur les liens internet pour avoir plus de détails sur un protocole)

Paramétrage interfaces
OSPF - backbone area
OSPF - multi area
OSPF - stub area
Routage statique
Redistribution - static vers OSPF
Accès Telnet

 
 
 
 
 
 
 


3. CONFIGURATIONS

Vous devez configurer votre système Linux correctement pour pouvoir lancer Quagga avec succès.
Référez-vous au tutorial Quagga pour de l'assistance.
LINUX CONFIGURATIONS

Vérifiez que les démons ospfd et zebra sont activés sur Quagga A et Quagga B:

#vim /etc/quagga/daemons
zebra=yes
bgpd=no
ospfd=yes
ospf6d=no
ripd=no
ripngd=no
isisd=no


Si vous avez effectués des changements dans vos fichiers daemon, redémarrez le service quagga:

#vim /etc/init.d/quagga restart
Stopping Quagga daemons (prio:0): ospfd zebra (bgpd) (ripd) (ripngd) (ospf6= d) (isisd).
Removing all routes made by zebra.
Nothing to flush.
Loading capability module if not yet done.
Starting Quagga daemons (prio:10): zebra ospfd.


Configurez le nom d'hôte (hostname) de Quagga A dans le fichier /etc/quagga/vtysh.conf:

#vim /etc/quagga/vtysh.conf
!
! Sample
!
! service integrated-vtysh-config
hostname Quagga_A
username root nopassword
!


Configurez le nom d'hôte (hostname) de Quagga B dans le fichier /etc/quagga/vtysh.conf:

#vim /etc/quagga/vtysh.conf
!
! Sample
!
! service integrated-vtysh-config
hostname Quagga_B
username root nopassword
!


N'oubliez pas d'activer la redirection IP (IP forwarding) sur le routeur Quagga A!
Il n'est pas nécessaire d'activer la redirection IP sur le routeur Quagga B parce qu'il n'a qu'une interface réseau.

CONFIGURATIONS DES ROUTEURS

ROUTEUR CISCO 2651 IOS: 12.2-23a ROUTEUR QUAGGA A 0.99.6
interface FastEthernet0/1
  ip address 10.1.3.2 255.255.255.0
  no shutdown
interface eth0
  ip address 10.1.3.1/24
  link-detect
interface FastEthernet0/0
  ip address 10.1.4.2 255.255.255.0
  no shutdown
interface eth1
  ip address 10.1.1.1/24
  link-detect
interface Loopback 1
  ip address 10.200.1.3 255.255.255.255
 
interface lo
  ip address 10.200.1.2/32
  link-detect
hostname Cisco-2651
ip route 10.200.1.1/32 10.1.1.2
router ospf 1
  area 1 stub
  network 10.1.3.0 0.0.0.255 area 1
  network 10.1.4.0 0.0.0.255 area 1
  network 10.200.1.3 0.0.0.0 area 1
router ospf
  area 1 stub
  network 10.1.3.0/24 area 1
  network 10.1.1.0/24 area 0
  network 10.200.1.2/32 area 0
line vty 0 4
  no login
line vty
  no login
enable secret password enable password password

SWITCH L3 CISCO 3750
IOS: 12.2-25.SEE2

ROUTEUR QUAGGA B
0.99.6
interface vlan 1
  ip address 10.1.1.2 255.255.255.0
  no shutdown
interface eth0
  ip address 10.1.4.1/24
  link-detect
interface Loopback 1
  ip address 10.200.1.1 255.255.255.255
 
interface lo
  ip address 10.200.1.4/32
  link-detect
hostname 3750_L3
router ospf 1
 
  network 10.1.1.0 0.0.0.255 area 0
  
router ospf
  area 1 stub
  network 10.1.4.0/24 area 1
  network 10.200.1.4/32 area 1
line vty 0 4
  no login
line vty 0 4
  no login
enable secret password
 
enable password password
 
ip routing
ip multicast-routing distributed
VOIR LA CONFIGURATION COMPLÈTE DES ÉQUIPEMENTS:

Quagga A
Quagga B
Cisco 2651
Cisco 3750 L3



4. COMMANDES SHOW

CISCO 3750 L3 ROUTEUR QUAGGA A CISCO 2651 ROUTEUR QUAGGA B
CISCO 3750 LAYER 3

3750_L3##show interface vlan 1

Vlan1 is up, line protocol is up
  Hardware is EtherSVI, address is 0011.2233.4444 (bia 0011.2233.4444)
  Internet address is 10.1.1.2/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
    reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
    2120 packets input, 159981 bytes, 0 no buffer
    Received 0 broadcasts (57 IP multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    1425 packets output, 139335 bytes, 0 underruns
    0 output errors, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
3750_L3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route
     
Gateway of last resort is not set
     
  10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C   10.200.1.1/32 is directly connected, Loopback1
C   10.1.1.0/24 is directly connected, Vlan1
O   10.200.1.2/32 [110/11] via 10.1.1.1, 01:40:19, Vlan1
O IA   10.1.3.0/24 [110/11] via 10.1.1.1, 01:40:19, Vlan1
O IA   10.1.4.0/24 [110/12] via 10.1.1.1, 01:40:19, Vlan1
O IA   10.200.1.3/32 [110/12] via 10.1.1.1, 01:40:19, Vlan1
O IA   10.200.1.4/32 [110/22] via 10.1.1.1, 01:40:19, Vlan1
3750_L3#show ip ospf interface

Vlan1 is up, line protocol is up
  Internet Address 10.1.1.2/24, Area 0
  Process ID 1, Router ID 10.200.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 10.200.1.2, Interface address 10.1.1.1
  Backup Designated router (ID) 10.200.1.1, Interface address 10.1.1.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.200.1.2 (Designated Router)
  Suppress hello for 0 neighbor(s)
3750_L3#show ip ospf database

  OSPF Router with ID (10.200.1.1) (Process ID 1)
     
    Router Link States (Area 0)
               
Link ID   ADV Router Age Seq# Checksum Link count
10.200.1.1   10.200.1.1 117 0x8000001D 0x000A48 1  
10.200.1.2   10.200.1.2 731 0x8000001D 0x000A48 2  
               
    Net Link States (Area 0)
               
Link ID   ADV Router Age Seq# Checksum    
10.1.1.1   10.200.1.2 731 0x80000004 0x00C009    
               
    Summary Net Link States (Area 0)
               
Link ID   ADV Router Age Seq# Checksum    
10.1.3.0   10.200.1.2 1543 0x80000008 0x005E0A    
10.1.4.0   10.200.1.2 743 0x80000009 0x005B0A    
10.200.1.3   10.200.1.2 623 0x80000009 0x00019C    
10.200.1.4   10.200.1.2 923 0x8000000A 0x005938    
               
    Type-5 AS External Link States
               
Link ID   ADV Router Age Seq# Checksum Tag  
10.200.1.1   10.200.1.2 773 0x8000000 0x008A73 0  
3750_L3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.200.1.2 1 FULL/DR 00:00:34 10.1.1.1 Vlan1

Haut de la page       Menu commandes show

ROUTEUR QUAGGA A

Quagga_A#show interface description

Interface Status Protocol Description
eth0 up up  
eth1 up up  
lo up up  
Quagga_A#show interface eth0

Interface eth0 is up, line protocol is up
  index 2 metric 1 mtu 1500
  flags: <UP,BROADCAST,RUNNING,MULTICAST>
  HWaddr: 00:02:11:22:33:99
  inet 10.1.3.1/24 broadcast 10.1.3.255
  inet6 fe80::201:66ff:1122:3399/64
    2598 input packets (0 multicast), 213456 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    2491 output packets, 229815 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
Quagga_A (Linux level)#route -n

Kernel IP routing table
Destination Gateway Genmask Indic Metric Ref Use Iface
10.200.1.1 10.1.1.2 255.255.255.255 UGH 0 0 0 eth1
10.200.1.3 10.1.3.2 255.255.255.255 UGH 11 0 0 eth0
10.200.1.4 10.1.3.2 255.255.255.255 UGH 21 0 0 eth0
10.1.4.0 10.1.3.2 255.255.255.0 UG 11 0 0 eth0
10.1.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
10.1.3.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
Quagga_A#show ip route

Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    I - ISIS, B - BGP, > - selected route, * - FIB route
     
C>* 127.0.0.0/8 is directly connected, lo
C>* 10.200.1.2/32 is directly connected, lo
C>* 10.1.3.0/24 is directly connected, eth0
C>* 10.1.1.0/24 is directly connected, eth1
S>* 10.200.1.1/32 [1/0] via 10.1.1.2, eth1
O 10.1.1.0/24 [110/10] is directly connected, eth1, 03:30:30
O 10.1.3.0/24 [110/10] is directly connected, eth0, 03:30:39
O 10.200.1.2/32 [110/10] is directly connected, lo, 03:30:39
O>* 10.1.4.0/24 [110/11] via 10.1.3.2, eth0, 03:30:29
O>* 10.200.1.3/32 [110/11] via 10.1.3.2, eth0, 03:30:29
O>* 10.200.1.4/32 [110/21] via 10.1.3.2, eth0, 03:30:29
Quagga_A#show ip ospf interface

eth0 is up
  ifindex 2, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  Internet Address 10.1.3.1/24, Broadcast 10.1.3.255, Area 0.0.0.1 [Stub]
  MTU mismatch detection:enabled
  Router ID 10.200.1.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State Backup, Priority 1
  Designated Router (ID) 10.1.4.2, Interface Address 10.1.3.2
  Backup Designated Router (ID) 10.200.1.2, Interface Address 10.1.3.1
  Multicast group memberships: OSPFAllRouters OSPFDesignatedRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 6.220s
  Neighbor Count is 1, Adjacent neighbor count is 1
eth1 is up
  ifindex 3, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  Internet Address 10.1.1.1/24, Broadcast 10.1.1.255, Area 0.0.0.0
  MTU mismatch detection:enabled
  Router ID 10.200.1.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.200.1.2, Interface Address 10.1.1.1
  Backup Designated Router (ID) 10.200.1.1, Interface Address 10.1.1.2
  Multicast group memberships: OSPFAllRouters OSPFDesignatedRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 5.460s
  Neighbor Count is 1, Adjacent neighbor count is 1
lo is up
  ifindex 1, MTU 16436 bytes, BW 0 Kbit <UP,LOOPBACK,RUNNING>
  Internet Address 10.200.1.2/32, Area 0.0.0.0
  MTU mismatch detection:enabled
  Router ID 10.200.1.2, Network Type LOOPBACK, Cost: 10
  Transmit Delay is 1 sec, State Loopback, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: <None>
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in inactive
  Neighbor Count is 0, Adjacent neighbor count is 0
Quagga_A#show ip ospf database

  OSPF Router with ID (10.200.1.2)
             
    Router Link States (Area 0.0.0.0)
             
Link ID   ADV Router Age Seq# CkSum Link count
10.200.1.1   10.200.1.1 1496 0x8000001c 0x0c47 1
10.200.1.2   10.200.1.2 67 0x80000010 0xdfa2 2
             
    Net Link States (Area 0.0.0.0)
             
Link ID   ADV Router Age Seq# CkSum  
10.1.1.1   10.200.1.2 67 0x80000004 0xc009  
             
    Summary Link States (Area 0.0.0.0)
             
Link ID   ADV Router Age Seq# CkSum Route
10.1.3.0   10.200.1.2 909 0x80000008 0x5e0a 10.1.3.0/24
10.1.4.0   10.200.1.2 79 0x80000009 0x5b0a 10.1.4.0/24
10.200.1.3   10.200.1.2 1790 0x80000008 0x039b 10.200.1.3/32
10.200.1.4   10.200.1.2 259 0x8000000a 0x5938 10.200.1.4/32
             
    Router Link States (Area 0.0.0.1 [Stub])
             
Link ID   ADV Router Age Seq# CkSum Link count
10.1.4.2   10.1.4.2 736 0x80000010 0x8742 3
10.200.1.2   10.200.1.2 59 0x8000000c 0xe98b 1
10.200.1.4   10.200.1.4 470 0x8000000a 0x5927 2
             
    Net Link States (Area 0.0.0.1 [Stub])
             
Link ID   ADV Router Age Seq# CkSum  
10.1.3.2   10.1.4.2 736 0x80000007 0xea43  
10.1.4.2   10.1.4.2 736 0x80000008 0xf930  
             
    Summary Link States (Area 0.0.0.1 [Stub])
             
Link ID   ADV Router Age Seq# CkSum Route
0.0.0.0   10.200.1.2 179 0x80000009 0xcfb0 0.0.0.0/0
10.1.1.0   10.200.1.2 1309 0x80000007 0x94d8 10.1.1.0/24
10.200.1.2   10.200.1.2 309 0x80000009 0x1f82 10.200.1.2/32
             
    AS External Link States
             
10.200.1.1   10.200.1.2 109 0x80000009 0x8a73 E2 10.200.1.1/32 [0x0]
Quagga_A#show ip border-routers

============ OSPF router routing table =============
 
Quagga_A#show ip neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
10.200.1. 1 Full/Backup 32.136s 10.1.1.2 eth1:10.1.1.1 1 0 0
10.1.4.2 1 Full/DR 36.102s 10.1.3.2 eth0:10.1.3.1 0 0 0
Quagga_A#show ip ospf route

============ OSPF network routing table ============
N 10.1.1.0/24 [10] area: 0.0.0.0
    directly attached to eth1
N 10.1.3.0/24 [10] area: 0.0.0.1
    directly attached to eth0
N 10.1.4.0/24 [11] area: 0.0.0.1
    via 10.1.3.2, eth0
N 10.200.1.2/32 [10] area: 0.0.0.0
    directly attached to lo
N 10.200.1.3/32 [11] area: 0.0.0.1
    via 10.1.3.2, eth0
N 10.200.1.4/32 [21] area: 0.0.0.1
    via 10.1.3.2, eth0
     
============ OSPF router routing table =============
     
============ OSPF external routing table ===========
Quagga_A#show ip forwarding

IP forwarding is on
Voir des explications sur la redirection IP sur Linux (IP forwarding).

Haut de la page       Menu commandes show

CISCO 2651

Cisco_2651#show ip interface brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.4.2 YES NVRAM up up
FastEthernet0/1 10.1.3.2 YES NVRAM up up
Loopback1 10.200.1.3 YES manual up up
Cisco-2651#show interface FastEthernet 0/0

FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0011.2211.3345 (bia 0011.2211.3345)
  Internet address is 10.1.4.2/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:01:20, output 00:00:09, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
    477 packets input, 46396 bytes
    Received 303 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    603 packets output, 58014 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
Cisco-2651#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route
     
Gateway of last resort is 10.1.3.1 to network 0.0.0.0
     
  10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C   10.1.4.0/24 is directly connected, FastEthernet0/0
C   10.1.3.0/24 is directly connected, FastEthernet0/1
C   10.200.1.3/32 is directly connected, Loopback1
O   10.200.1.4/32 [110/11] via 10.1.4.1, 02:06:38, FastEthernet0/0
O IA   10.1.1.0/24 [110/11] via 10.1.3.1, 02:06:38, FastEthernet0/1
O IA   10.200.1.2/32 [110/11] via 10.1.3.1, 02:06:38, FastEthernet0/1
O*IA 0.0.0.0/0 [110/2] via 10.1.3.1, 02:06:40, FastEthernet0/1
Cisco-2651#show ip ospf border-routers

OSPF Process 1 internal Routing Table
 
Codes: i - Intra-area route, I - Inter-area route
 
i 10.200.1.2 [1] via 10.1.3.1, FastEthernet0/1, ABR, Area 1, SPF 12
Cisco-2651#show ip ospf database

  OSPF Router with ID (10.1.4.2) (Process ID 1)
             
    Router Link States (Area 1)
             
Link ID   ADV Router Age Seq# Checksum Link count
10.1.4.2   10.1.4.2 1800 0x8000000D 0x008D3F 3
10.200.1.2   10.200.1.2 414 0x80000009 0x00EF88 1
10.200.1.4   10.200.1.4 821 0x80000007 0x005F24 2
             
    Net Link States (Area 1)
             
Link ID   ADV Router Age Seq# Checksum  
10.1.3.2   10.1.4.2 1800 0x80000004 0x00F040  
10.1.4.2   10.1.4.2 1800 0x80000005 0x00FF2D  
             
    Summary Net Link States (Area 1)
             
Link ID   ADV Router Age Seq# Checksum  
0.0.0.0   10.200.1.2 595 0x80000006 0x00D5AD  
10.1.1.0   10.200.1.2 79 0x80000004 0x009AD5  
10.200.1.2   10.200.1.2 1790 0x80000006 0x00257F  
Cisco-2651#show ip ospf interface

Loopback1 is up, line protocol is up
  Internet Address 10.200.1.3/32, Area 1
  Process ID 1, Router ID 10.1.4.2, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.1.4.2/24, Area 1
  Process ID 1, Router ID 10.1.4.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.1.4.2, Interface address 10.1.4.2
  Backup Designated router (ID) 10.200.1.4, Interface address 10.1.4.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 4
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.200.1.4 (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
FastEthernet0/1 is up, line protocol is up
  Internet Address 10.1.3.2/24, Area 1
  Process ID 1, Router ID 10.1.4.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.1.4.2, Interface address 10.1.3.2
  Backup Designated router (ID) 10.200.1.2, Interface address 10.1.3.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.200.1.2 (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
Haut de la page       Menu commandes show

ROUTEUR QUAGGA B

Quagga_B#show interface description

Interface Status Protocol Description
eth0 up up  
lo up up  
Quagga_B#show interface eth0

Interface eth0 is up, line protocol is up
  index 2 metric 1 mtu 1500
  flags: <UP,BROADCAST,RUNNING,MULTICAST>
  HWaddr: 00:02:11:22:88:88
  inet 10.1.4.1/24 broadcast 10.1.4.255
  inet6 fe80::201:66ff:1122:8888/64
    2598 input packets (0 multicast), 213456 bytes, 0 dropped
    0 input errors, 0 length, 0 overrun, 0 CRC, 0 frame
    0 fifo, 0 missed
    2491 output packets, 229815 bytes, 0 dropped
    0 output errors, 0 aborted, 0 carrier, 0 fifo, 0 heartbeat
    0 window, 0 collisions
Quagga_B (Linux level)#route -n

Kernel IP routing table
Destination Gateway Genmask Indic Metric Ref Use Iface
10.200.1.3 10.1.4.2 255.255.255.255 UGH 11 0 0 eth0
10.200.1.2 10.1.4.2 255.255.255.255 UGH 21 0 0 eth0
10.1.4.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
10.1.1.0 10.1.4.2 255.255.255.0 UG 21 0 0 eth0
10.1.3.0 10.1.4.2 255.255.255.0 UG 11 0 0 eth0
0.0.0.0 10.1.4.2 0.0.0.0 UG 12 0 0 eth0
Quagga_B#show ip route

Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    I - ISIS, B - BGP, > - selected route, * - FIB route
     
C>* 10.1.4.0/24 is directly connected, eth0
C>* 10.200.1.4/32 is directly connected, lo
C>* 127.0.0.0/8 is directly connected, lo
O 10.1.4.0/24 [110/10] is directly connected, eth0, 01:04:26
O 10.200.1.4/32 [110/10] is directly connected, lo, 01:04:26
O 10.1.1.0/24 [110/21] via 10.1.4.2, eth0, 00:28:00
O>* 10.1.3.0/24 [110/11] via 10.1.4.2, eth0, 00:52:54
O>* 10.200.1.2/32 [110/21] via 10.1.4.2, eth0, 00:28:04
O>* 10.200.1.3/32 [110/11] via 10.1.4.2, eth0, 01:04:17
O>* 0.0.0.0/0 [110/12] via 10.1.4.2, eth0, 00:28:04
Quagga_B#show ip ospf border-routers

============ OSPF router routing table =============
R 10.200.1.2 [11] area: 0.0.0.1, ABR
    via 10.1.4.2, eth0
Quagga_B#show ip ospf database

  OSPF Router with ID (10.200.1.4)
             
    Router Link States (Area 0.0.0.1 [Stub])
             
Link ID   ADV Router Age Seq# CkSum Link count
10.1.4.2   10.1.4.2 1718 0x8000000a 0x933c 3
10.200.1.2   10.200.1.2 1690 0x80000005 0xf784 1
10.200.1.4   10.200.1.4 294 0x80000004 0x6521 2
             
    Net Link States (Area 0.0.0.1 [Stub])
             
Link ID   ADV Router Age Seq# CkSum  
10.1.3.2   10.1.4.2 1718 0x80000001 0xf63d  
10.1.4.2   10.1.4.2 1887 0x80000002 0x062a  
             
    Summary Link States (Area 0.0.0.1 [Stub])
             
Link ID   ADV Router Age Seq# CkSum Route
0.0.0.0   10.200.1.2 163 0x80000003 0xdbaa 0.0.0.0/0
10.1.1.0   10.200.1.2 1715 0x80000001 0xa0d2 10.1.1.0/24
10.200.1.2   10.200.1.2 143 0x80000003 0x2b7c 10.200.1.2/32
Quagga_B#show ip ospf route

============ OSPF network routing table ============
N IA 0.0.0.0/0 [12] area: 0.0.0.1
      via 10.1.4.2, eth0
N IA 10.1.1.0/24 [21] area: 0.0.0.1
      via 10.1.4.2, eth0
N   10.1.3.0/24 [11] area: 0.0.0.1
      via 10.1.4.2, eth0
N   10.1.4.0/24 [10] area: 0.0.0.1
      directly attached to eth0
N IA 10.200.1.2/32 [21] area: 0.0.0.1
      via 10.1.4.2, eth0
N   10.200.1.3/32 [11] area: 0.0.0.1
      via 10.1.4.2, eth0
N   10.200.1.4/32 [10] area: 0.0.0.1
      directly attached to lo
       
============ OSPF router routing table =============
R   10.200.1.2 [11] area: 0.0.0.1, ABR
      via 10.1.4.2, eth0
       
============ OSPF external routing table ===========
Quagga_B#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
10.1.4.2 1 Full/DR 33.812s 10.1.4.2 eth0:10.1.4.1 0 0 0
Quagga_B#show ip forwarding

IP forwarding is off
Voir des explications sur la redirection IP sur Linux (IP forwarding).

Quagga_B#show ip ospf interface

eth0 is up
  ifindex 2, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  Internet Address 10.1.4.1/24, Broadcast 10.1.4.255, Area 0.0.0.1 [Stub]
  MTU mismatch detection:enabled
  Router ID 10.200.1.4, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State Backup, Priority 1
  Designated Router (ID) 10.1.4.2, Interface Address 10.1.4.2
  Backup Designated Router (ID) 10.200.1.4, Interface Address 10.1.4.1
  Multicast group memberships: OSPFAllRouters OSPFDesignatedRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 6.517s
  Neighbor Count is 1, Adjacent neighbor count is 1
lo is up
  ifindex 1, MTU 16436 bytes, BW 0 Kbit <UP,LOOPBACK,RUNNING>
  Internet Address 10.200.1.4/32, Area 0.0.0.1 [Stub]
  MTU mismatch detection:enabled
  Router ID 10.200.1.4, Network Type LOOPBACK, Cost: 10
  Transmit Delay is 1 sec, State Loopback, Priority 1
  No designated router on this network
  No backup designated router on this network
  Multicast group memberships: <None>
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in inactive
  Neighbor Count is 0, Adjacent neighbor count is 0
Quagga_B#traceroute 10.200.1.1

traceroute to 10.200.1.1 (10.200.1.1), 30 hops max, 40 byte packets
  1 10.1.4.2 0.918 ms 0.960 ms 0.951 ms
  2 10.1.3.1 0.416 ms 0.336 ms 0.340 ms
  3 10.1.1.2 0.790 ms * 0.834 ms
Traceroute doit être installé sur votre système d'exploitation pour être utilisé sous Quagga.
Voir le tutorial Quagga pour de l'assistance.

Haut de la page       Menu commandes show