TOTAL
Depuis Dec 2006
1'942'871 Visiteurs
4'218'042 Pages

Stats Nov 2010
82'909 Visiteurs
146'476 Pages
196 pays
Statistiques completes



Aidez-nous à traduire
nos tutoriaux!

REJOINGNEZ
l'équipe OpenManiak.
VYATTA - The Easy Tutorial - Etude 6 - NAT

Vyatta Etude 6 - NAT
Dernière modif: Dec 26 2007


Outil
Installation
Ergonomie
Forum



Détails Vyatta, c'est quoi?
Captures d'écran
Prérequis
Tutorial Vyatta
Commandes Vyatta & Cisco
Comparaison Vyatta/Quagga/Cisco (Section Quagga)
Étude de cas 1 - Routage Statique VC 2.0
Étude de cas 2 - OSPF Simple VC 2.0
Étude de cas 3 - OSPF Avancé VC 2.0
Étude de cas 4 - BGP VC 3.0
Étude de cas 5 - VRRP VC 2.2
Étude de cas 6 - NAT VC 2.0
Étude de cas 7 - DHCP VC 2.2
Étude de cas 8 - IPSec VC 2.2
Étude de cas 9 - Packages VC 3.0
Étude de cas 10 - Pontage (Bridging) VC 3.0
Étude de cas 11 - CDP VC 3.0



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.


1. NAT - STATIQUE 2. PAT - STATIQUE 3. NAT - DYNAMIQUE 4. NAT - MASCARADE


1.1 PRINCIPE 1.2 SCHEMA 1.3 CONFIGURATIONS 1.4 COMMANDES SHOW


1. PRINCIPE

Version de Vyatta utilisée: VC 2.0 Feb 20, 2007
Le NAT statique, où une adresse IP est traduite vers une autre adresse IP, peut être utilisé pour atteindre un serveur web interne depuis Internet.
Un avantage du NAT statique comparé aux autres types de NAT est que les ports TCP ou UDP ne sont pas modifiés pendant la traduction (NAT).

Dans notre exemple, nous avons configurés un NAT statique source et destination.


2. SCHEMA

cisco vyatta case study statique nat Fonctionnalités testées:

(cliquez sur les liens internet pour avoir plus de détails sur un protocole)

Interface settings
Telnet
NAT - Statique
Routage statique
 
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

CISCO ROUTER 2651 IOS: 12.2(15)T17 VYATTA ROUTER VC2 Feb 20, 2007
interface FastEthernet0/0
  description Server A
  ip address 10.0.0.1 255.255.255.0
  ip nat inside
edit interfaces ethernet eth1
  set description ServerB
  set address 10.0.0.1 prefix-length 24
 
interface FastEthernet0/1
  description Vyatta
  ip address 50.0.0.2 255.255.255.0
  ip nat outside
edit interfaces ethernet eth0
  set description Cisco
  set address 50.0.0.1 prefix-length 24
 
ip route 60.0.0.0 255.255.255.240
50.0.0.1
set protocols static route 70.0.0.0/28 next-hop
50.0.0.2
ip nat inside source static 10.0.0.2
70.0.0.2

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
set service nat rule 1
edit service nat rule 1
  set type destination
  set translation-type static
  set inbound-interface eth0
  set protocols all
  set source network 0.0.0.0/0
  set destination address 60.0.0.56
  set inside-address address 10.0.0.2

set service nat rule 2
edit service nat rule 2
  set type source
  set translation-type static
  set outbound-interface eth0
  set protocols all
  set source address 10.0.0.2
  set destination network 0.0.0.0/0
  set outside-address address 60.0.0.2
line vty 0 4
  no login
set service telnet
 
enable secret password
 
edit system login user vyatta
  set authentification plaintext-password password


4. COMMANDES SHOW

vyatta@vyatta>show nat rules

vyatta output show nat rules

vyatta@vyatta>show nat statistics

vyatta output show nat statistics

vyatta:~#tcpdump -v -p icmp
(doit être lancé en tant que root sous Linux)

vyatta output tcpdump

Router#show ip nat translations

Cisco output show ip nat translations

Router#show ip nat statistics

Cisco output show ip nat statistics

Router#debug ip nat
Router#terminal monitor

Cisco output debug ip nat

VERIFICATIONS DE CONNECTIVITES DE BOUT EN BOUT:

Depuis le serveur web A:
c:\>tracert 60.0.0.2

windows tracert

Depuis le serveur web B:
c:\>tracert 70.0.0.2

windows tracert

Haut de la page


2.1 PRINCIPE 2.2 SCHEMA 2.3 CONFIGURATIONS 2.4 COMMANDES SHOW


1. PRINCIPE

Le PAT (Port Address Translation) statique signifie qu'une adresse IP et un port de niveau 4 (TCP/UDP) sont traduits en une adresse IP est un port de niveau 4.
Il peut être utilisé pour atteindre un service spécifique depuis Internet.

Dans notre exemple, nous avons configurés du PAT statique destination.


2. SCHEMA

Vyatta Cisco étude de cas statique pat Fonctionnalités testées:

(cliquez sur les liens internet pour avoir plus de détails sur un protocole)

Interface settings
Telnet
PAT - Statique
Routage statique
 
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

CISCO ROUTER 2651 IOS: 12.2(15)T17 VYATTA ROUTER VC2 Feb 20, 2007
interface FastEthernet0/0
  description Server A
  ip address 10.0.0.1 255.255.255.0
  ip nat inside
edit interfaces ethernet eth1
  set description ServerB
  set address 10.0.0.1 prefix-length 24
 
interface FastEthernet0/1
  description Vyatta
  ip address 50.0.0.2 255.255.255.0
  ip nat outside
edit interfaces ethernet eth0
  set description Cisco
  set address 50.0.0.1 prefix-length 24
 
ip route 60.0.0.0 255.255.255.240
50.0.0.1
set protocols static route 70.0.0.0/28 next-hop
50.0.0.2
ip nat inside source static
tcp 10.0.0.2 21 70.0.0.2 21
 
 
 
 
 
 
 
 
set service nat rule 1
edit service nat rule 1
  set type destination
  set translation-type static
  set inbound-interface eth0
  set protocols tcp
  set source network 0.0.0.0/0
  set destination address 60.0.0.2
  set destination port-name ftp
  set inside-address address 10.0.0.2
line vty 0 4
  no login
set service telnet
 
enable secret password
 
edit system login user vyatta
  set authentification plaintext-password password


4. COMMANDES SHOW

vyatta@vyatta>show nat rules

vyatta output show nat rules

vyatta@vyatta>show nat statistics

vyatta output show nat statistics

vyatta:~#tcpdump port 21
(doit être lancé en tant que root sous Linux)

vyatta output tcpdump

Router#show ip nat translations

cisco output show ip nat translations

Router#show ip nat statistics

cisco output show ip nat statistics

Router#debug ip nat
Router#terminal monitor

cisco output debug ip nat

Haut de la page


3.1 PRINCIPE 3.2 SCHEMA 3.3 CONFIGURATIONS 3.4 COMMANDES SHOW


1. PRINCIPE

Le NAT dynamique signifie qu'une adresse IP membre d'un pool d'adresses est traduite vers une adresse IP membre d'un autre pool d'adresses.
Il peut être utilisé quand on veut lier deux réseaux ayant la même plage d'adresse IP.

Dans noter exemple, nous avons configurés du NAT dynamique de source.


2. SCHEMA

Cisco vyatta étude de cas dynamique nat Fonctionnalités testées:

(cliquez sur les liens internet pour avoir plus de détails sur un protocole)

Interface settings
Telnet
NAT - Dynamique
Routage statique
 
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

CISCO ROUTER 2651 IOS: 12.2(15)T17 VYATTA ROUTER VC2 Feb 20, 2007
interface FastEthernet0/0
  description Server A
  ip address 10.0.0.1 255.255.255.0
  ip nat inside
edit interfaces ethernet eth1
  set description ServerB
  set address 10.0.0.1 prefix-length 24
 
interface FastEthernet0/1
  description Vyatta
  ip address 50.0.0.2 255.255.255.0
  ip nat outside
edit interfaces ethernet eth0
  set description Cisco
  set address 50.0.0.1 prefix-length 24
 
ip route 60.0.0.0 255.255.255.240
50.0.0.1
set protocols static route 70.0.0.0/28 next-hop
50.0.0.2
ip nat pool nat-pool 70.0.0.0 70.0.0.15
netmask 255.255.255.240
ip nat inside source list 1 pool nat-pool
access-list 1 permit 10.0.0.0 0.0.0.255
 
 
 
 
 
set service nat rule 1
edit service nat rule 1
  set type source
  set translation-type dynamic
  set outbound-interface eth0
  set protocols all
  set source network 10.0.0.0/24
  set destination network 0.0.0.0/0
  set outside-address address 60.0.0.0/28
line vty 0 4
  no login
set service telnet
 
enable secret password
 
edit system login user vyatta
  set authentification plaintext-password password


4. COMMANDES SHOW

vyatta@vyatta>show nat rules

vyatta output show nat rules

vyatta@vyatta>show nat statistics

vyatta output show nat statistics

vyatta:~#tcpdump -v
(doit être lancé en tant que root sous Linux)

vyatta output tcpdump

Router#show ip nat translations

cisco output show ip nat translations

Router#show ip nat statistics

cisco output show ip nat statistics

Router#debug ip nat
Router#terminal monitor

cisco output debug ip nat

VERIFICATIONS DE CONNECTIVITES DE BOUT EN BOUT:

Depuis le poste de travail A:
c:\>tracert 50.0.0.1

windows tracert

Depuis le poste de travail B:
c:\>tracert 50.0.0.2

windows tracert

Haut de la page


4.1 PRINCIPE 4.2 SCHEMA 4.3 CONFIGURATIONS 4.4 COMMANDES SHOW


1. PRINCIPE

Le NAT mascarade signifie que des adresses IP sources membres d'un pool d'adresses sont traduites vers une seule adresse IP.

Il est typiquement utilisé pour un groupe d'utilisateurs ayant des adresses privées et souhaitant accéder à Internet.


2. SCHEMA

cisco vyatta étude de cas nat masquerade overloading Fonctionnalités testées:

(cliquez sur les liens internet pour avoir plus de détails sur un protocole)

Interface settings
Telnet
NAT - Mascarade
Routage statique
 
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

CISCO ROUTER 2651 IOS: 12.2(15)T17 VYATTA ROUTER VC2 Feb 20, 2007
interface FastEthernet0/0
  description Server A
  ip address 10.0.0.1 255.255.255.0
  ip nat inside
edit interfaces ethernet eth1
  set description ServerB
  set address 10.0.0.1 prefix-length 24
 
interface FastEthernet0/1
  description Vyatta
  ip address 50.0.0.2 255.255.255.0
  ip nat outside
edit interfaces ethernet eth0
  set description Cisco
  set address 50.0.0.1 prefix-length 24
 
ip route 60.0.0.0 255.255.255.240
50.0.0.1
set protocols static route 70.0.0.0/28 next-hop
50.0.0.2
ip nat inside source list 1 interface
FastEthernet0/1 overload
access-list 1 permit 10.0.0.0 0.0.0.255
 
 
 
 
 
set service nat rule 1
edit service nat rule 1
  set type source
  set translation-type masquerade
  set inbound-interface eth0
  set protocols all
  set source network 10.0.0.0/24
  set destination address 0.0.0.0/0
line vty 0 4
  no login
set service telnet
 
enable secret password
 
edit system login user vyatta
  set authentification plaintext-password password


4. COMMANDES SHOW

vyatta@vyatta>show nat rules

vyatta output show nat rules

vyatta@vyatta>show nat statistics

vyatta output show nat statistics

vyatta:~#tcpdump -v
(doit être lancé en tant que root sous Linux)

vyatta output tcpdump

Router#show ip nat translations
(telnet depuis poste de travail A vers Vyatta)

cisco output show ip nat translations

Router#show ip nat statistics

cisco output show ip nat statistics

Router#debug ip nat
Router#terminal monitor

cisco output debug ip nat
VERIFICATIONS DE CONNECTIVITES DE BOUT EN BOUT:

Depuis le poste de travail A:
c:\>tracert 50.0.0.1

tracert windows

Depuis le poste de travail B:
c:\>tracert 50.0.0.2

tracert windows

Haut de la page