TOTAL
Depuis Dec 2006
1'942'871 Visiteurs
4'218'042 Pages

Stats Nov 2010
82'909 Visiteurs
146'476 Pages
196 pays
Statistiques completes



Aidez-nous à traduire
nos tutoriaux!

REJOINGNEZ
l'équipe OpenManiak.
VYATTA - Le Tutorial Facile - Etude 3 - OPSF Advancé

Vyatta Etude 3 - OPSF Avancé
Dernière modif: Dec 26 2007


Outil
Installation
Ergonomie
Forum



Détails Vyatta, c'est quoi?
Captures d'écran
Prérequis
Tutorial Vyatta
Commandes Vyatta & Cisco
Comparaison Vyatta/Quagga/Cisco (Section Quagga)
Étude de cas 1 - Routage Statique VC 2.0
Étude de cas 2 - OSPF Simple VC 2.0
Étude de cas 3 - OSPF Avancé VC 2.0
Étude de cas 4 - BGP VC 3.0
Étude de cas 5 - VRRP VC 2.2
Étude de cas 6 - NAT VC 2.0
Étude de cas 7 - DHCP VC 2.2
Étude de cas 8 - IPSec VC 2.2
Étude de cas 9 - Packages VC 3.0
Étude de cas 10 - Pontage (Bridging) VC 3.0
Étude de cas 11 - CDP VC 3.0



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. PRINCIPE 2. SCHEMA 3. CONFIGURATIONS 4. COMMANDES SHOW
See a similar scenario with the Quagga router.


1. PRINCIPE

Version de Vyatta utilisée: VC 2.0 Feb 20, 2007
Nous allons tester dans cet troisième exemple un environement d'un niveau de difficuté moyen où deux postes de travail sont reliés entre eux par deux aires OSPF dont une est de type stub (stub area). D'autres fonctionnalités listées ci-dessous sont testées en même temps.

Le routeur Vyatta A et le switch de niveau 3 (Layer 3) sont localisés dans une aire de type stub, ils ont des routes OSPF intra (O) et inter-aires (OIA) dans leur table de routage mais aucune route OSPF de type externe.
Pour atteindre, depuis les deux routers mentionnés ci-dessus des réseaux OSPF externes comme 10.200.1.4 dans notre étude, il y a une route OSPF par défaut vers le "border router" (routeur vyatta B).
Quagga B est appelé "border router" (routeur frontière) parce qu'il est à la fois dans l'aire 1 et l'aire 0 (backbone area).

Dans le cadre de notre étude, la route statique 10.200.1.4 est redistribuée dans OSPF au niveau du routeur Vyatta B pour créer "artificiellement" un réseau OSPF externe (OE2). A cause de l'aire stub, ce réseau ne doit pas se diffuser dans les tables de routages du router Vyatta A et du Switch de niveau 3.


Soyez attentif que la synchronisation ntp ainsi que les paramètres DCHP relay ne fonctionnent pas sur la version VC2.
Lisez la stratégie de Vyatta à propos de la version gratuite. (Community Edition)


2. SCHEMA

vyatta cisco étude de cas opsf advanced 3750 2651 Functionalities tested:

(click on the web links to have more details about a protocol)

Interface settings
OSPF - backbone area
OSPF - multi area
OSPF - stub area
Routage statique
Redistribution statique - OSPF
DHCP
SNMP
Syslog
802.1Q - trunking
SSH
Telnet
ntp
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

SWITCH NIVEAU 2 (LAYER 2) IOS: 12.2-25.SEB4 Voir la configuration complète
interface GigabitEthernet 1/0/1
  description Vyatta_A
  switchport mode trunk
  switchport trunk encapsulation dot1q
interface GigabitEthernet1/0/2
  description DHCP_client
  switchport access vlan 2
interface GigabitEthernet1/0/3
  switchport access vlan 3
interface GigabitEthernet1/0/4
  switchport access vlan 100
interface vlan 1
  shutdown
interface vlan 2
  ip address 10.101.2.1 255.255.255.0
interface vlan 3
  ip address 10.101.3.1 255.255.255.0
interface vlan 100
  ip address 10.101.1.1 255.255.255.0
ip default-gateway 10.101.1.2
logging 10.102.1.99
logging trap debugging
snmp-server community TeddyBear RO 50
access-list 50 permit 10.102.1.99
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
ROUTEUR VYATTA A VC2 Feb 20, 2007 Voir la configuration complète
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.1.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Switch_Layer2
  set vif 2 address 10.101.2.2 prefix-length 24
  set vif 3 address 10.101.3.2 prefix-length 24
  set vif 100 address 10.101.1.2 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.1 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.1
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 interface lo address 10.200.1.1
  set area 0.0.0.1 interface eth0 address 10.100.1.2
  set area 0.0.0.1 interface eth1.2 address 10.101.2.2
  set area 0.0.0.1 interface eth1.3 address 10.101.3.2
  set area 0.0.0.1 interface eth1.100 address 10.101.1.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location Paris-router
  set community TeddyBear contact Guillaume
edit system
  set host-name VyattaA
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set service dhcp-server name server1
edit service dhcp-server name server1
  set start 10.101.2.101 stop 10.101.2.120
  set default-router 10.101.2.2
  set network-mask 24
  set interface eth1.2
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
SWITCH NIVEAU 3 (LAYER 3) IOS: 12.2-25.SEE2 Voir la configuration complète
hostname 3750-Cisco
ip routing
ip multicast-routing distributed
interface Vlan1
  ip address 10.100.1.1 255.255.255.0
interface Vlan2
  ip address 10.100.2.1 255.255.255.0
interface FastEthernet1/0/1
  description Vyatta_A
interface FastEthernet1/0/2
  description Vyatta_B
  switchport access vlan 2
interface Loopback1
  ip address 10.200.1.3 255.255.255.255
router ospf 1
  area 1 stub
  network 10.100.1.0 0.0.0.255 area 1
  network 10.100.2.0 0.0.0.255 area 1
  network 10.200.1.3 0.0.0.0 area 1
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
ip domain-name domain.net
crypto key generate rsa
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
ROUTEUR VYATTA B VC2 Feb 20, 2007 Voir la configuration complète
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.2.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Cisco_2651
  set address 10.1.2.1 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.2 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.2
  set area 0.0.0.0 interface eth1 address 10.1.2.1
  set area 0.0.0.0 interface lo address 10.200.1.2
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 default-lsa disable false
  set area 0.0.0.1 interface eth1 address 10.100.2.2
  set export static-to-OPSF
set protocols static route 10.200.1.4/32 next-hop 10.1.2.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location London-router
  set community TeddyBear contact Philou
set policy policy-statement static-to-OSPF
edit policy policy-statement static-to-OSPF
  set term from protocol static
  set term then action accept
edit system
  set host-name VyattaB
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
CISCO 2651 IOS: 12.2-23a Voir la configuration complète
hostname cisco-2651
interface FastEthernet 0/0
  description Vyatta B router
  ip address 10.1.2.2 255.255.255.0
interface FastEthernet 0/1
  description SNMP/Syslog/TFTP server
  ip address 10.102.1.1 255.255.255.0
interface Loopback1
  ip address 10.200.1.4 255.255.255.255
router ospf 1
  network 10.1.2.0 0.0.0.255 area 0
  network 10.102.1.0 0.0.0.255 area 0
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
line vty 0 4
  no login
enable secret password
ntp master


Configuration Microsoft Windows du Desktop A
Configuration Microsoft Windows du Desktop B

Sauvez les configurations sur le serveur TFTP 10.102.1.99:

Equipement_Cisco#copy run tftp
Equipement_Vyatta#save tftp://10.102.1.99/vyatta.conf

Vérification SNMP depuis le serveur SNMP (Ubuntu ou Debian):

Installer le serveur SNMP:
#apt-get install snmp

snmpstatus -vniveau_de_la_communauté -c nom_de_la communauté adresse_IP
exemple:
#snmpstatus -v2c -c TeddyBear 10.100.2.2

Haut de la page


4. COMMANDES SHOW

SWITCH NIVEAU 2 (LAYER 2)

Switch_L2#show ip route

cisco output show ip route

Switch_L2#show interfaces GigabitEthernet 1/0/1 trunk

cisco output show  interfaces GigabitEthernet 1/0/1 trunk

Switch_L2#show ntp associations

cisco output show ntp associations

ROUTEUR VYATTA A

vyatta@VyattaA#show route

vyatta output show route

vyatta@VyattaA#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaA#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaA#show dhcp lease

vyatta output show dhcp lease

vyatta@VyattaA#show dhcp statistics

vyatta output show dhcp statistics

vyatta@VyattaA#show ntp associations

vyatta output show ntp associations

SWITCH NIVEAU 3 (LAYER 3)

3750-Cisco#show ip route

cisco output show ip route

3750-Cisco#show ip ospf neighbor

cisco output show ip ospf neighbor

3750-Cisco#show ip ospf database

cisco output show ip ospf database

3750-Cisco#show ntp associations

cisco output show ntp associations

ROUTEUR VYATTA B

vyatta@VyattaB#show route

vyatta output show route

vyatta@VyattaB#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaB#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaB#show ntp associations

vyatta output show ntp associations

ROUTEUR 2651

cisco-2651#show ip route

cisco output show ip route

cisco-2651#show ip ospf neighbor

cisco output show ip ospf neighbor

cisco-2651#show ip ospf database

cisco output show ip ospf database

cisco-2651#show ntp associations

cisco output show ntp associations

cisco-2651#show ntp status

cisco output show ntp status

VERIFICATIONS DE CONNECTIVITE DE BOUT EN BOUT:

Depuis le Desktop A vers le Desktop B
C:\>tracert 10.102.1.99

windows output tracert

Depuis le Desktop B vers le Desktop A
C:\>tracert 10.101.2.119

windows output tracert

Haut de la page