VYATTA - Lak priručnik - Proučavanje slučaja 3 - OSPF napredno

Vyatta Proučavanje slučaja 3 - OSPF napredno
Zadnje osvježenje: Mar 18 2008


Tool
Install
Ergonomy
Forum



Pojedinosti Što je Vyatta?
Prikazi_zaslona
Preduvjeti
Priručnik Vyatta-e
Vyatta & Cisco naredbe
Vyatta/Cisco/Quagga usporedba (Quagga dio)
Proučavanje slučaja 1 - Statične rute (VC 2.0)
Proučavanje slučaja 2 - OSPF jednostavno (VC 2.0)
Proučavanje slučaja 3 - OSPF napredno (VC 2.0)
Proučavanje slučaja 4 - BGP (VC 3.0)
Proučavanje slučaja 5 - VRRP (VC 2.2)
Proučavanje slučaja 6 - NAT (VC 2.0)
Proučavanje slučaja 7 - DHCP (VC 2.2)
Proučavanje slučaja 8 - IPSec (VC 2.2)
Proučavanje slučaja 9 - Paketi (VC 3.0)
Proučavanje slučaja 10 - Premoštenja (VC 3.0)
Proučavanje slučaja 11 - CDP (VC 3.0)

Croatian translation by Oliver Mucafir .



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. NAČELAN SLUČAJ 2. SLIKA 3. POSTAVKE 4. PRIKAZ NAREDBI
Pogledajte sličan scenarij s Quagga routerom.


1. NAČELAN SLUČAJ

Korištena verzija Vyatte: VC 2.0, 20.veljače 2007.
Testirat ćemo u ovom trećem primjeru okruženje srednje razine složenosti gdje su dvije radne površine zajedno povezane s dva OPSF područja, jedno OSPF područje je označeno kao stub područje. Ostale dalje izlistane Vyatta funkcionalnosti testirane su u isto vrijeme.

Vyatta A router i Layer 3 Switch locirani su u stub području. Oni imaju OPSF rute unutar (O) i rute među područjima (OIA) u svojim routing tablicama ali nemaju vanjsku OSPF rutu. Da bi se rutirale te vanjske OPSF mreže kao 10.200.1.4 (pogledajte sljedeći stavak), tu je podrazumijevana OSPF ruta ka graničnom routeru (Vyatta A router) na routerima unutar područja 1. Vyatta A je granični router zato jer je u području 0 ili backbone područje i u području 1.

U svrhu proučavanja ovog slučaja, statična ruta 10.200.1.4 je redistribuirana u OSPF na Vyatta B router da "umjetno" stvori vanjsku OPSF mrežu označenu kao OE2. Zbog stub područja, ova mreža ne bi trebala biti proširena na Vyatta A router i na Layer 3 Switch.


Molimo, budite svijesni da Vyatta ntp sinkronizacija i postavke dhcp releja ne rade na Vyatti VC2.
Pročitajte Vyatta policu o izdanju Zajednice.


2. SLIKA

vyatta cisco case study opsf advanced 3750 2651 Testirane funkcionalnosti:

(kliknite na web poveznicu za više pojedinosti o protokolu)

Postavke sučelja
OSPF - backbone područje
OSPF - multi područje
OSPF - stub područje
Statično rutiranje
Redistribucija – statično do OSPF
DHCP poslužitelj
SNMP postavke
Syslog postavke
802.1Q - trunking
SSH pristup
Telnet pristup
ntp sinkronizacija
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


3. CONFIGURAZIONE

SWITCH LAYER 2 IOS: 12.2-25.SEB4 Pogledajte cjelovite postavke
interface GigabitEthernet 1/0/1
  description Vyatta_A
  switchport mode trunk
  switchport trunk encapsulation dot1q
interface GigabitEthernet1/0/2
  description DHCP_client
  switchport access vlan 2
interface GigabitEthernet1/0/3
  switchport access vlan 3
interface GigabitEthernet1/0/4
  switchport access vlan 100
interface vlan 1
  shutdown
interface vlan 2
  ip address 10.101.2.1 255.255.255.0
interface vlan 3
  ip address 10.101.3.1 255.255.255.0
interface vlan 100
  ip address 10.101.1.1 255.255.255.0
ip default-gateway 10.101.1.2
logging 10.102.1.99
logging trap debugging
snmp-server community TeddyBear RO 50
access-list 50 permit 10.102.1.99
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
VYATTA A ROUTER VC2 Feb 20, 2007 Pogledajte cjelovite postavke
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.1.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Switch_Layer2
  set vif 2 address 10.101.2.2 prefix-length 24
  set vif 3 address 10.101.3.2 prefix-length 24
  set vif 100 address 10.101.1.2 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.1 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.1
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 interface lo address 10.200.1.1
  set area 0.0.0.1 interface eth0 address 10.100.1.2
  set area 0.0.0.1 interface eth1.2 address 10.101.2.2
  set area 0.0.0.1 interface eth1.3 address 10.101.3.2
  set area 0.0.0.1 interface eth1.100 address 10.101.1.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location Paris-router
  set community TeddyBear contact Guillaume
edit system
  set host-name VyattaA
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set service dhcp-server name server1
edit service dhcp-server name server1
  set start 10.101.2.101 stop 10.101.2.120
  set default-router 10.101.2.2
  set network-mask 24
  set interface eth1.2
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
SWITCH LAYER 3 IOS: 12.2-25.SEE2 Pogledajte cjelovite postavke
hostname 3750-Cisco
ip routing
ip multicast-routing distributed
interface Vlan1
  ip address 10.100.1.1 255.255.255.0
interface Vlan2
  ip address 10.100.2.1 255.255.255.0
interface FastEthernet1/0/1
  description Vyatta_A
interface FastEthernet1/0/2
  description Vyatta_B
  switchport access vlan 2
interface Loopback1
  ip address 10.200.1.3 255.255.255.255
router ospf 1
  area 1 stub
  network 10.100.1.0 0.0.0.255 area 1
  network 10.100.2.0 0.0.0.255 area 1
  network 10.200.1.3 0.0.0.0 area 1
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
ip domain-name domain.net
crypto key generate rsa
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
VYATTA B ROUTER VC2 Feb 20, 2007 Pogledajte cjelovite postavke
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.2.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Cisco_2651
  set address 10.1.2.1 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.2 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.2
  set area 0.0.0.0 interface eth1 address 10.1.2.1
  set area 0.0.0.0 interface lo address 10.200.1.2
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 default-lsa disable false
  set area 0.0.0.1 interface eth1 address 10.100.2.2
  set export static-to-OPSF
set protocols static route 10.200.1.4/32 next-hop 10.1.2.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location London-router
  set community TeddyBear contact Philou
set policy policy-statement static-to-OSPF
edit policy policy-statement static-to-OSPF
  set term from protocol static
  set term then action accept
edit system
  set host-name VyattaB
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
CISCO 2651 IOS: 12.2-23a Pogledajte cjelovite postavke
hostname cisco-2651
interface FastEthernet 0/0
  description Vyatta B router
  ip address 10.1.2.2 255.255.255.0
interface FastEthernet 0/1
  description SNMP/Syslog/TFTP server
  ip address 10.102.1.1 255.255.255.0
interface Loopback1
  ip address 10.200.1.4 255.255.255.255
router ospf 1
  network 10.1.2.0 0.0.0.255 area 0
  network 10.102.1.0 0.0.0.255 area 0
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
line vty 0 4
  no login
enable secret password
ntp master


Desktop A Microsoft Windows Configurazione
Desktop B Microsoft Windows Configurazione

Spremi postavke na 10.102.1.99 TFTP poslužitelju:

Cisco_device#copy run tftp
Vyatta_device#save tftp://10.102.1.99/vyatta.conf

SNMP provjera sa SNMP poslužitelja (Ubuntu ili Debian).

Instaliraj SNMP poslužitelj:
#apt-get install snmp

snmpstatus -vcommunity_level -c community_name ip_address
primjer:
#snmpstatus -v2c -c TeddyBear 10.100.2.2

Vrh stranice


4. PRIKAZ NAREDBI

SWITCH LAYER 2

Switch_L2#show ip route

cisco output show ip route

Switch_L2#show interfaces GigabitEthernet 1/0/1 trunk

cisco output show  interfaces GigabitEthernet 1/0/1 trunk

Switch_L2#show ntp associations

cisco output show ntp associations

VYATTA A ROUTER

vyatta@VyattaA#show route

vyatta output show route

vyatta@VyattaA#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaA#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaA#show dhcp lease

vyatta output show dhcp lease

vyatta@VyattaA#show dhcp statistics

vyatta output show dhcp statistics

vyatta@VyattaA#show ntp associations

vyatta output show ntp associations

SWITCH LAYER 3

3750-Cisco#show ip route

cisco output show ip route

3750-Cisco#show ip ospf neighbor

cisco output show ip ospf neighbor

3750-Cisco#show ip ospf database

cisco output show ip ospf database

3750-Cisco#show ntp associations

cisco output show ntp associations

VYATTA B ROUTER

vyatta@VyattaB#show route

vyatta output show route

vyatta@VyattaB#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaB#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaB#show ntp associations

vyatta output show ntp associations

ROUTER 2651

cisco-2651#show ip route

cisco output show ip route

cisco-2651#show ip ospf neighbor

cisco output show ip ospf neighbor

cisco-2651#show ip ospf database

cisco output show ip ospf database

cisco-2651#show ntp associations

cisco output show ntp associations

cisco-2651#show ntp status

cisco output show ntp status

END TO END PROVJERE POVEZANOSTI:

Od Radne površine A prema Radnoj površini B
C:\>tracert 10.102.1.99

windows output tracert

Od Radne površine B prema Radnoj površini A
C:\>tracert 10.101.2.119

windows output tracert

Vrh stranice