VYATTA - Semplice guida - Caso Studio 3 - OPSF Advanced

Vyatta Case 3 - OPSF Adv.
Last Update: Jan 03 2008


Tool
Install
Ergonomy
Forum



Details Cosa è Vyatta?
Screenshots
Prerequisiti
Tutorial Vyatta
Confronto comandi Vyatta & Cisco
Vyatta/Cisco/Quagga confronto (sezione Quagga)
Caso Studio 1 - Static routes (VC 2.0)
Caso Studio 2 - OSPF simple (VC 2.0)
Caso Studio 3 - OSPF advanced (VC 2.0)
Caso Studio 4 - BGP (VC 3.0)
Caso Studio 5 - VRRP (VC 2.2)
Caso Studio 6 - NAT (VC 2.0)
Caso Studio 7 - DHCP (VC 2.2)
Caso Studio 8 - IPSec (VC 2.2)
Caso Studio 9 - Packages (VC 3.0)
Caso Studio 10 - Bridging (VC 3.0)
Caso Studio 11 - CDP (VC 3.0)

Italian translation by Giovanni Fredducci.



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. CASO 2. IMMAGINI 3. CONFIGURAZIONE 4. COMANDI
Vedi uno scenario simile con Quagga router.


1. CASO

Vyatta versione: VC 2.0 Feb 20, 2007
In questo terzo caso, di media difficoltà, connetteremo due desktop collegati tra loro da due OPSF aree , una OSPF area è tagged come “stub” area. Le altre funzionalità di Vyatta elencate sotto saranno testate nello stesso tempo.

Vyatta A router e un Layer 3 Switch sono ubicati nella stub area; hanno OPSF intra (O) e inter-area routes (OIA) nella routing tables ma non nella esterna OSPF route. La route di questi esterni OPSF networks è 10.200.1.4 (vedi paragrafo successivo), c’è un default OSPF route, router esterno (Vyatta A router) nei routers nell’area 1. Vyatta A è un router esternoperchè è nell’area 0 o backbone area e in area 1.

Per lo scopo del nostro caso , l’ip 10.200.1.4 è static route e redistrubiusce nel OSPF sul Vyatta B router "artificially" crea un esterno OPSF network tagged come OE2. Perché la stub area, questo network non dovrebbe propagare sul Vyatta A router e il Layer 3 Switch.


Ricorda che Vyatta ntp synchronization e dhcp relay parametric non operano in Vyatta VC2.
Leggi Vyatta policy Community Edition.


2. IMMAGINI

vyatta cisco case study opsf advanced 3750 2651 Funzionalità testate:

(click sui link per avere maggiori dettagli sui protocolli)

Interface settings
OSPF - backbone area
OSPF - multi area
OSPF - stub area
Static routing
Redistribution - static to OSPF
DHCP server
SNMP settings
Syslog settings
802.1Q - trunking
SSH access
Telnet access
ntp synchronization
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


3. CONFIGURAZIONE

SWITCH LAYER 2 IOS: 12.2-25.SEB4 Vedi l’intera configurazione
interface GigabitEthernet 1/0/1
  description Vyatta_A
  switchport mode trunk
  switchport trunk encapsulation dot1q
interface GigabitEthernet1/0/2
  description DHCP_client
  switchport access vlan 2
interface GigabitEthernet1/0/3
  switchport access vlan 3
interface GigabitEthernet1/0/4
  switchport access vlan 100
interface vlan 1
  shutdown
interface vlan 2
  ip address 10.101.2.1 255.255.255.0
interface vlan 3
  ip address 10.101.3.1 255.255.255.0
interface vlan 100
  ip address 10.101.1.1 255.255.255.0
ip default-gateway 10.101.1.2
logging 10.102.1.99
logging trap debugging
snmp-server community TeddyBear RO 50
access-list 50 permit 10.102.1.99
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
VYATTA A ROUTER VC2 Feb 20, 2007 Vedi l’intera configurazione
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.1.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Switch_Layer2
  set vif 2 address 10.101.2.2 prefix-length 24
  set vif 3 address 10.101.3.2 prefix-length 24
  set vif 100 address 10.101.1.2 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.1 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.1
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 interface lo address 10.200.1.1
  set area 0.0.0.1 interface eth0 address 10.100.1.2
  set area 0.0.0.1 interface eth1.2 address 10.101.2.2
  set area 0.0.0.1 interface eth1.3 address 10.101.3.2
  set area 0.0.0.1 interface eth1.100 address 10.101.1.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location Paris-router
  set community TeddyBear contact Guillaume
edit system
  set host-name VyattaA
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set service dhcp-server name server1
edit service dhcp-server name server1
  set start 10.101.2.101 stop 10.101.2.120
  set default-router 10.101.2.2
  set network-mask 24
  set interface eth1.2
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
SWITCH LAYER 3 IOS: 12.2-25.SEE2 Vedi l’intera configurazione
hostname 3750-Cisco
ip routing
ip multicast-routing distributed
interface Vlan1
  ip address 10.100.1.1 255.255.255.0
interface Vlan2
  ip address 10.100.2.1 255.255.255.0
interface FastEthernet1/0/1
  description Vyatta_A
interface FastEthernet1/0/2
  description Vyatta_B
  switchport access vlan 2
interface Loopback1
  ip address 10.200.1.3 255.255.255.255
router ospf 1
  area 1 stub
  network 10.100.1.0 0.0.0.255 area 1
  network 10.100.2.0 0.0.0.255 area 1
  network 10.200.1.3 0.0.0.0 area 1
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
ip domain-name domain.net
crypto key generate rsa
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
VYATTA B ROUTER VC2 Feb 20, 2007 Vedi l’intera configurazione
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.2.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Cisco_2651
  set address 10.1.2.1 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.2 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.2
  set area 0.0.0.0 interface eth1 address 10.1.2.1
  set area 0.0.0.0 interface lo address 10.200.1.2
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 default-lsa disable false
  set area 0.0.0.1 interface eth1 address 10.100.2.2
  set export static-to-OPSF
set protocols static route 10.200.1.4/32 next-hop 10.1.2.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location London-router
  set community TeddyBear contact Philou
set policy policy-statement static-to-OSPF
edit policy policy-statement static-to-OSPF
  set term from protocol static
  set term then action accept
edit system
  set host-name VyattaB
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
CISCO 2651 IOS: 12.2-23a Vedi l’intera configurazione
hostname cisco-2651
interface FastEthernet 0/0
  description Vyatta B router
  ip address 10.1.2.2 255.255.255.0
interface FastEthernet 0/1
  description SNMP/Syslog/TFTP server
  ip address 10.102.1.1 255.255.255.0
interface Loopback1
  ip address 10.200.1.4 255.255.255.255
router ospf 1
  network 10.1.2.0 0.0.0.255 area 0
  network 10.102.1.0 0.0.0.255 area 0
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
line vty 0 4
  no login
enable secret password
ntp master


Desktop A Microsoft Windows Configurazione
Desktop B Microsoft Windows Configurazione

Salva la configurazione sul server TFTP 10.102.1.99:

Cisco_device#copy run tftp
Vyatta_device#save tftp://10.102.1.99/vyatta.conf

SNMP controllato dal server SNMP (Ubuntu or Debian).

Installare SNMP server:
#apt-get install snmp

snmpstatus -vcommunity_level -c community_name ip_address
example:
#snmpstatus -v2c -c TeddyBear 10.100.2.2

Inizio pagina


4. COMANDI

SWITCH LAYER 2

Switch_L2#show ip route

cisco output show ip route

Switch_L2#show interfaces GigabitEthernet 1/0/1 trunk

cisco output show  interfaces GigabitEthernet 1/0/1 trunk

Switch_L2#show ntp associations

cisco output show ntp associations

VYATTA A ROUTER

vyatta@VyattaA#show route

vyatta output show route

vyatta@VyattaA#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaA#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaA#show dhcp lease

vyatta output show dhcp lease

vyatta@VyattaA#show dhcp statistics

vyatta output show dhcp statistics

vyatta@VyattaA#show ntp associations

vyatta output show ntp associations

SWITCH LAYER 3

3750-Cisco#show ip route

cisco output show ip route

3750-Cisco#show ip ospf neighbor

cisco output show ip ospf neighbor

3750-Cisco#show ip ospf database

cisco output show ip ospf database

3750-Cisco#show ntp associations

cisco output show ntp associations

VYATTA B ROUTER

vyatta@VyattaB#show route

vyatta output show route

vyatta@VyattaB#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaB#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaB#show ntp associations

vyatta output show ntp associations

ROUTER 2651

cisco-2651#show ip route

cisco output show ip route

cisco-2651#show ip ospf neighbor

cisco output show ip ospf neighbor

cisco-2651#show ip ospf database

cisco output show ip ospf database

cisco-2651#show ntp associations

cisco output show ntp associations

cisco-2651#show ntp status

cisco output show ntp status

controllo connettività END TO END:

Da Desktop A a Desktop B
C:\>tracert 10.102.1.99

windows output tracert

Da Desktop B a Desktop A
C:\>tracert 10.101.2.119

windows output tracert

Inizio pagina