VYATTA - Semplice guida - Caso Studio 1 - Static Routing

Vyatta Case 1 - Static Routing
Last Update: Jan 03 2008


Tool
Install
Ergonomy
Forum



Details Cosa è Vyatta?
Screenshots
Prerequisiti
Tutorial Vyatta
Confronto comandi Vyatta & Cisco
Vyatta/Cisco/Quagga confronto (sezione Quagga)
Caso Studio 1 - Static routes (VC 2.0)
Caso Studio 2 - OSPF simple (VC 2.0)
Caso Studio 3 - OSPF advanced (VC 2.0)
Caso Studio 4 - BGP (VC 3.0)
Caso Studio 5 - VRRP (VC 2.2)
Caso Studio 6 - NAT (VC 2.0)
Caso Studio 7 - DHCP (VC 2.2)
Caso Studio 8 - IPSec (VC 2.2)
Caso Studio 9 - Packages (VC 3.0)
Caso Studio 10 - Bridging (VC 3.0)
Caso Studio 11 - CDP (VC 3.0)

Italian translation by Giovanni Fredducci.



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. CASO 2. IMMAGINI 3. CONFIGURAZIONE 4. COMANDI
Vedi uno scenario simile con Quagga router.


1. CASO

Vyatta versione: VC 2.0 Feb 20, 2007
In questo primo caso vi vedrà un semplice esempio dove il routing è fatto con “static routes”.


Leggi Vyatta policy della versione Community Edition.


2. IMMAGINI

vyatta cisco 2651 3750 static routing Funzionalità testate:

Interface settings
Static routes
Telnet access

 
 
   
 
 
 
 
 
 
 
 


3. CONFIGURAZIONE

CISCO ROUTER 2651 VYATTA A ROUTER
interface FastEthernet0/1
  ip address 10.1.3.2 255.255.255.0
edit interfaces ethernet eth0
  set address 10.1.3.1 prefix-length 24
interface FastEthernet0/0
  ip address 10.1.4.2 255.255.255.0
edit interfaces ethernet eth1
  set address 10.1.1.1 prefix-length 24
hostname Cisco-2651 set system host-name VyattaA
ip route 10.1.0.0 255.255.0.0 10.1.3.1
 
ip route 10.200.1.4 255.255.255.255 10.1.4.1
ip route 10.200.1.1 255.255.255.255 10.1.3.1
set protocols static route 10.1.0.0/16 next-hop 10.1.3.2
set protocols static route 10.200.1.4/32 next-hop 10.1.3.2
set protocols static route 10.200.1.1/32 next-hop 10.1.1.2
line vty 0 4
  no login
set service telnet
 
enable secret password
 
edit system login user vyatta
set authentification plaintext-password password

CISCO SWITCH L3 3750

VYATTA B ROUTER
interface vlan 1
  ip address 10.1.1.2 255.255.255.0
edit interfaces ethernet eth1
  set address 10.1.4.1 prefix-length 24
interface Loopback 1
  ip address 10.200.1.1 255.255.255.255
edit interfaces loopback lo
  set address 10.200.1.4 prefix-length 32
hostname 3750_L3 set system host-name VyattaB
ip route 0.0.0.0 0.0.0.0 10.1.1.1 set system static gateway-address 10.1.4.2
line vty 0 4
no login
set service telnet
 
enable secret password
 
edit system login user vyatta
set authentification plaintext-password password
ip routing
ip multicast-routing distributed
VEDI L’INTERA CONFIGURAZIONE:

VyattaA
VyattaB
Cisco 2651
Cisco 3750 L3


4. COMANDI

ROUTING TABLE

vyatta@VyattaA#show route

vyatta output show route

Cisco-2651#show ip route

cisco output show ip route

vyatta@VyattaB#show route

vyatta output show route

3750_L3#show ip route

cisco output show ip route

INTERFACCE

vyatta@VyattaA#show interfaces ethernet eth0 physical

vyatta output show interfaces ethernet eth0 physical

vyatta@VyattaA#show interfaces ethernet eth0 statistics

vyatta output show interfaces ethernet eth0 statistics

Cisco-2651#show ip interface brief

cisco output show ip interface brief

Cisco-2651#show ip interface FastEthernet 0/1

cisco output show ip interface FastEthernet 0/1


vyatta@VyattaA#show version

vyatta output show version

Cisco-2651#show version

cisco output show version

Inizio pagina