VYATTA - Lak priručnik - Proučavanje slučaja 7 - DHCP

Vyatta Proučavanje slučaja 7 - DHCP
Zadnje osvježenje: Mar 18 2008


Tool
Install
Ergonomy
Forum



Pojedinosti Što je Vyatta?
Prikazi_zaslona
Preduvjeti
Priručnik Vyatta-e
Vyatta & Cisco naredbe
Vyatta/Cisco/Quagga usporedba (Quagga dio)
Proučavanje slučaja 1 - Statične rute (VC 2.0)
Proučavanje slučaja 2 - OSPF jednostavno (VC 2.0)
Proučavanje slučaja 3 - OSPF napredno (VC 2.0)
Proučavanje slučaja 4 - BGP (VC 3.0)
Proučavanje slučaja 5 - VRRP (VC 2.2)
Proučavanje slučaja 6 - NAT (VC 2.0)
Proučavanje slučaja 7 - DHCP (VC 2.2)
Proučavanje slučaja 8 - IPSec (VC 2.2)
Proučavanje slučaja 9 - Paketi (VC 3.0)
Proučavanje slučaja 10 - Premoštenja (VC 3.0)
Proučavanje slučaja 11 - CDP (VC 3.0)

Croatian translation by Oliver Mucafir .



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. NAČELAN SLUČAJ 2. SLIKA 3. POSTAVKE 4. PRIKAZ NAREDBI


1. NAČELAN SLUČAJ

Korištena verzija Vyatte: VC 2.2 30. rujna 2007.
DHCP (Dynamic Host Configuration Protocol) je protokol koji koriste računala zvana klijenti, da bi dobila IP adresu od poslužitelja.
Osim IP adrese, poslužitelj daje neobavezna podešenja kao subnet masku, podrazumijevani gateway ili DNS poslužitelj prema klijentu.
Da bi zatražio IP adresu, klijent prvo šalje zahtjeve na lokalnom subnetu da bi našao DHCP poslužitelje.
Podrazumijevano, routeri ne šalju dalje zahtjeve ali se mogu podesiti da ih šalju DHCP poslužitelju.
Kada router šalje dalje zahtjev naziva se DHCP relej.

Provjerite odlomak o analizi paketa da bi prikupili informacije o DHCP operations request procesu.


2. SLIKA

vyatta cisco case study VRRP   vyatta cisco case study VRRP Testirane funkcionalnosti:

(klikni na web poveznicu za više pojedinosti o protokolu)

Postavke sučelja
Telnet pristup
DHCP poslužitelj
DHCP relej
 
 
 
 
 
 
 
 
 
 
 
 
 
 


3. POOSTAVKE

VYATTA ROUTER A VC2.2 Aug 30, 2007
Vidi cjelovita podešenja
 
CISCO ROUTER A 2621 IOS: 12.2(23a)
Vidi cjelovita podešenja
 
edit interfaces ethernet eth0
  set address 10.0.2.1 prefix-length 24
interface FastEthernet0/0
  ip address 10.0.2.1 255.255.255.0
set system host-name Vyatta-RouterA hostname Cisco-routerA
set service telnet
 
line vty 0 4
  no login
edit system login user vyatta
  set authentification plaintext-password
enable secret password
 
set service dhcp-server shared-network-name mydhcp
edit service dhcp-server shared-network-name mydhcp
  set subnet 10.0.2.0/24
  set subnet 10.0.1.0/24
  edit subnet 10.0.1.0/24
    dns-server 10.0.2.3
    default-router 10.0.1.2
    set start 10.0.1.200 stop 10.0.1.210
    set start 10.0.1.212 stop 10.0.1.222

 
 
service dhcp
 
ip dhcp pool mydhcp
 
 
  network 10.0.1.0 255.255.255.0
 
  dns-server 10.0.2.3
  default-router 192.168.1.1
 
 
ip dhcp excluded-address 10.0.1.0 10.0.1.199
ip dhcp excluded-address 10.0.1.223 10.0.1.255
ip dhcp excluded-address 10.0.1.211
set protocols static route 0.0.0.0/0 next-hop 10.0.2.2
 
ip route 0.0.0.0 0.0.0.0 10.0.2.2
 
 
VYATTA ROUTER B VC2.2 Aug 30, 2007
Vidi cjelovita podešenja
 
CISCO ROUTER B 2621 IOS: 12.4(16)
Vidi cjelovita podešenja
 
edit interfaces ethernet eth0
  set address 10.0.1.2 prefix-length 24
interface FastEthernet0/0
  ip address 10.0.1.2 255.255.255.0
edit interfaces ethernet eth1
  set address 10.0.2.2 prefix-length 24
interface FastEthernet0/1
  ip address 10.0.2.2 255.255.255.0
set system host-name Vyatta-RouterB hostname Cisco-routerB
set service telnet
 
line vty 0 4
  no login
edit system login user vyatta
  set authentification plaintext-password
enable secret password
 
edit service dhcp-relay
  set server 10.0.2.1
set service dhcp-relay interface eth0
set service dhcp-relay interface eth1
ip helper-address 10.0.2.1
  
  
 
DESKTOP:

Forzare il rinnovo dhcp:

Linux: dhclient eth0
Windows:
Start -> Esegui -> cmd
ipconfig /renew


4. PRIKAZ NAREDBI & ANALIZA PAKETA:

1. VYATTA – PROUČAVANJE SLUČAJA 2. CISCO – PROUČAVANJE SLUČAJA



1. VYATTA - PROUČAVANJE SLUČAJA

Vyatta_Router>show version

Baseline Version: vc2-2
Built by: root@vyatta.com
Built on: Thu Aug 23 20:41:03 UTC 2007
Build ID: aa2e45f-1a45b2b-518c9cc-a9aa9f8-4c29b36-6890d5d-200708232041

Cisco-Router#show dhcp leases

IP address Hardware Address Lease expiration Pool Client Name
------------ ------------------- --------------------- ------- -------------
10.0.1.222 00:99:88:77:66:55 2007/09/11 23:59:46 mydhcp Client_Laptop

Cisco-Router#show dhcp statistics

Total DHCP requests for all pools: 11      
Total DHCP responses for all pools: 3      
         
pool   pool size # leased # avail
-----   -------- -------- ------
mydhcp   0 1 -1

Cisco-RouterA#show route

0.0.0.0/0 [static(1)] > to 10.0.2.2 via eth0
10.0.2.0/24 [connected(0)] > to 10.0.2.1 via eth0
127.0.0.0/8 [connected(0)] > to 127.0.0.1 via lo

Cisco-RouterB#show dhcp statisctics

dhcp server is not running

Cisco-RouterB#show route

10.0.1.0/24 [connected(0)] > to 10.0.1.2 via eth0
10.0.2.0/24 [connected(0)] > to 10.0.2.2 via eth1
127.0.0.0/8 [connected(0)] > to 127.0.0.1 via lo

ANALISI PACCHETTI:

Wireshark (on the Desktop) and Wireshark (na Radnoj površini) i TCPdump (na Vyatta routeru) korišteni su da bi hvatali pakete za vrijeme trajanja procesa traženje DHCP IP adrese.

Radna površina: DHCP klijent)

Ovaj prikaz jasno pokazuje DHCP operacije procesa u četiri stupnja:

- DHCP Discover:
- DHCP Offer:

- DHCP Request:

- DHCP Acknowledgement:
 
Klijent šalje zahtjev da bi našao DHCP poslužitelj.
Poslužitelj šalje jedinstvenu poruku s IP adresom klijentu.
Klijent šalje obavijest mogućim drugim DHCP poslužiteljima da je primio IP adresu.
Poslužitelj šalje klijentu jedinstvenu poruku s neobaveznim podešenjima kao što je podrazumijevani gateway.
Važno je naglasiti, u slučaju da trebate podesiti pravila vatrozida, da paketi koje je poslao klijent koriste UDP izvorni port 68 i UDP odredišni port 67. Kada su poslani natrag od poslužitelja klijentu, tada koriste UDP izvorni port 67 i UDP odredišni port 68.

Vyatta-RouterA:
(DHCP poslužitelj)
tcpdump -n port 67

IP 10.0.2.2.67 > 10.0.2.1.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 300
IP 10.0.2.1.67 > 10.0.1.2.67: BOOTP/DHCP, Reply, length 300
IP 10.0.2.2.67 > 10.0.2.1.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 329
IP 10.0.2.1.67 > 10.0.1.2.67: BOOTP/DHCP, Reply, length 300

Vyatta-RouterB: (DHCP relej)

tcpdump -n port 67

IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 300
IP 10.0.1.2.67 > 10.0.1.222.68: BOOTP/DHCP, Reply, length 300
IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 329
IP 10.0.1.2.67 > 10.0.1.222.68: BOOTP/DHCP, Reply, length 300


Vrh stranice      Prikaži meni s naredbama



2. CISCO – PROUČAVANJE SLUČAJA

Cisco-RouterA#show ip route

Gateway of last resort is 10.0.2.2 to network 0.0.0.0

      10.0.0.0/24 is subnetted, 1 subnets
C         10.0.2.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.0.2.2
Cisco-RouterA#show ip dhcp binding

IP address
 
Client-ID/
Hardware address
Lease expiration
 
Type
 
10.0.1.200 0100.9988.7766.55 Mar 02 1993 12:45 AM Automatic
Cisco-RouterA#show ip dhcp server statistics

Memory usage 13393
Address pools 1
Database agents 0
Automatic bindings 1
Manual bindings 0
Expired bindings 0
Malformed messages 0
   
Message Received
BOOTREQUEST 0
DHCPDISCOVER 7
DHCPREQUEST 9
DHCPDECLINE 0
DHCPRELEASE 6
DHCPINFORM 0
   
Message Sent
BOOTREPLY 0
DHCPOFFER 7
DHCPACK 8
DHCPNAK 1
Cisco-RouterB#show ip route

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 2 subnets
C         10.0.2.0 is directly connected, FastEthernet0/1
C         10.0.1.0 is directly connected, FastEthernet0/0

ANALIZA PAKETA:

Wireshark (na Radnoj površini) i TCPdump (na Vyatta routeru) korišteni su da bi hvatali pakete za vrijeme trajanja procesa traženje DHCP IP adrese.

Radna površina: (DHCP klijent)

Ovaj prikaz jasno pokazuje DHCP operacije procesa u četiri stupnja:

- DHCP Discover:
- DHCP Offer:

- DHCP Request:

- DHCP Acknowledgement:
 
Klijent šalje zahtjev da bi našao DHCP poslužitelj.
Poslužitelj šalje jedinstvenu poruku s IP adresom klijentu.
Klijent šalje obavijest mogućim drugim DHCP poslužiteljima da je primio IP adresu.
Poslužitelj šalje klijentu jedinstvenu poruku s neobaveznim podešenjima kao što je podrazumijevani gateway.
Važno je naglasiti, u slučaju da trebate podesiti pravila vatrozida, da paketi koje je poslao klijent koriste UDP izvorni port 68 i UDP odredišni port 67. Kada su poslani natrag od poslužitelja klijentu, tada koriste UDP izvorni port 67 i UDP odredišni port 68.

Cisco-RouterA: (DHCP poslužitelj)

#debug ip dhcp server packety

DHCPD: DHCPDISCOVER received from client 0100.9988.7766.55 through relay 10.0.1.2.
DHCPD: Sending DHCPOFFER to client 0100.9988.7766.55 (10.0.1.200).
DHCPD: unicasting BOOTREPLY for client 0099.8877.6655 to relay 10.0.1.2.
DHCPD: DHCPREQUEST received from client 0100.9988.7766.55.
DHCPD: Sending DHCPACK to client 0100.9988.7766.55 (10.0.1.200).
DHCPD: unicasting BOOTREPLY for client 0099.8877.6655 to relay 10.0.1.2.


"01" znakovi ispred MAC adrese predstavljaju tip Ethernet medija.

Cisco-RouterB: (DHCP relej)

#debug ip dhcp server packety

DHCPD: setting giaddr to 10.0.1.2.
DHCPD: BOOTREQUEST from 0100.9988.7766.55 forwarded to 10.0.2.1.
DHCPD: forwarding BOOTREPLY to client 0099.8877.6655.
DHCPD: creating ARP entry (10.0.1.200, 0099.8877.6655).
DHCPD: unicasting BOOTREPLY to client 0099.8877.6655 (10.0.1.200).
DHCPD: Finding a relay for client 0100.9988.7766.55 on interface FastEthernet0/0.
DHCPD: setting giaddr to 10.0.1.2.
DHCPD: BOOTREQUEST from 0100.9988.7766.55 forwarded to 10.0.2.1.
DHCPD: forwarding BOOTREPLY to client 0099.8877.6655.
DHCPD: creating ARP entry (10.0.1.200, 0099.8877.6655).
DHCPD: unicasting BOOTREPLY to client 0099.8877.6655 (10.0.1.200).


Vrh stranice      Prikaži meni s naredbama