TOTAL
Depuis Dec 2006
1'942'871 Visiteurs
4'218'042 Pages

Stats Nov 2010
82'909 Visiteurs
146'476 Pages
196 pays
Statistiques completes



Aidez-nous à traduire
nos tutoriaux!

REJOINGNEZ
l'équipe OpenManiak.
VYATTA - The Easy Tutorial - Etude 7 - DHCP

Vyatta Etude 7 - DHCP
Dernière modif: Dec 26 2007


Outil
Installation
Ergonomie
Forum



Détails Vyatta, c'est quoi?
Captures d'écran
Prérequis
Tutorial Vyatta
Commandes Vyatta & Cisco
Comparaison Vyatta/Quagga/Cisco (Section Quagga)
Étude de cas 1 - Routage Statique VC 2.0
Étude de cas 2 - OSPF Simple VC 2.0
Étude de cas 3 - OSPF Avancé VC 2.0
Étude de cas 4 - BGP VC 3.0
Étude de cas 5 - VRRP VC 2.2
Étude de cas 6 - NAT VC 2.0
Étude de cas 7 - DHCP VC 2.2
Étude de cas 8 - IPSec VC 2.2
Étude de cas 9 - Packages VC 3.0
Étude de cas 10 - Pontage (Bridging) VC 3.0
Étude de cas 11 - CDP VC 3.0



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.



1. PRINCIPE 2. SCHEMA 3. CONFIGURATIONS 4. COMMANDES SHOW


1. PRINCIPE

Version de Vyatta utilisée: VC 2.2 Aug 30, 2007
DHCP pour Dynamic Host Configuration Protocol, est un protocole utilisé par des ordinateurs appelés clients pour obtenir une adresse IP d'un serveur.
En plus d'une adresse IP, le serveur fournit des paramètres optionnels au client comme un masque de sous-réseau, une passerelle par défaut ou un serveur DNS.
Pour faire la requête d'une adresse IP, le client diffuse (broadcast) d'abord sur le sous-réseau local pour trouver des serveurs DHCP.
Par défaut, les routeurs ne font pas suivre les diffusions (broadcasts) mais ils peuvent être configurés pour les envoyer directement vers des serveurs DHCP.
Un routeur faisant suivre une requête DHCP est appelé un relai DHCP (DHCP relay).

Rendez-vous à la section "analyse des paquets" pour obtenir plus d'information à propos du processus de requête des operations DHCP.


2. SCHEMA

vyatta cisco case study VRRP   vyatta cisco case study VRRP Fonctionnalités testées:

(cliquez sur les liens internet pour avoir plus de détails sur un protocole)

Paramètrage d'interface
Accès Telnet
DHCP - serveur
DHCP - relai
 
 
 
 
 
 
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

ROUTEUR VYATTA A VC2.2 Aug 30, 2007
Voir la configuration complète
 
ROUTEUR CISCO A 2621 IOS: 12.2(23a)
Voir la configuration complète
 
edit interfaces ethernet eth0
  set address 10.0.2.1 prefix-length 24
interface FastEthernet0/0
  ip address 10.0.2.1 255.255.255.0
set system host-name Vyatta-RouterA hostname Cisco-routerA
set service telnet
 
line vty 0 4
  no login
edit system login user vyatta
  set authentification plaintext-password
enable secret password
 
set service dhcp-server shared-network-name mydhcp
edit service dhcp-server shared-network-name mydhcp
  set subnet 10.0.2.0/24
  set subnet 10.0.1.0/24
  edit subnet 10.0.1.0/24
    dns-server 10.0.2.3
    default-router 10.0.1.2
    set start 10.0.1.200 stop 10.0.1.210
    set start 10.0.1.212 stop 10.0.1.222

 
 
service dhcp
 
ip dhcp pool mydhcp
 
 
  network 10.0.1.0 255.255.255.0
 
  dns-server 10.0.2.3
  default-router 192.168.1.1
 
 
ip dhcp excluded-address 10.0.1.0 10.0.1.199
ip dhcp excluded-address 10.0.1.223 10.0.1.255
ip dhcp excluded-address 10.0.1.211
set protocols static route 0.0.0.0/0 next-hop 10.0.2.2
 
ip route 0.0.0.0 0.0.0.0 10.0.2.2
 
 
ROTUEUR VYATTA B VC2.2 Aug 30, 2007
Voir la configuration complète
 
ROUTEUR CISCO B 2621 IOS: 12.4(16)
Voir la configuration complète
 
edit interfaces ethernet eth0
  set address 10.0.1.2 prefix-length 24
interface FastEthernet0/0
  ip address 10.0.1.2 255.255.255.0
edit interfaces ethernet eth1
  set address 10.0.2.2 prefix-length 24
interface FastEthernet0/1
  ip address 10.0.2.2 255.255.255.0
set system host-name Vyatta-RouterB hostname Cisco-routerB
set service telnet
 
line vty 0 4
  no login
edit system login user vyatta
  set authentification plaintext-password
enable secret password
 
edit service dhcp-relay
  set server 10.0.2.1
set service dhcp-relay interface eth0
set service dhcp-relay interface eth1
ip helper-address 10.0.2.1
  
  
 
POSTE DE TRAVAIL (DESKTOP):

Pour forcer un renouvellement IP:

Linux: dhclient eth0
Windows:
Démarrer -> Executer -> cmd
ipconfig /renew


4. COMMANDES SHOW & ANALYSE DES PAQUETS:

1. ETUDE DE CAS VYATTA 2. ETUDE DE CAS CISCO



1. ETUDE DE CAS VYATTA

Vyatta_RouterA>show version

Baseline Version: vc2-2
Built by: root@vyatta.com
Built on: Thu Aug 23 20:41:03 UTC 2007
Build ID: aa2e45f-1a45b2b-518c9cc-a9aa9f8-4c29b36-6890d5d-200708232041
Vyatta_RouterA>show dhcp leases

IP address Hardware Address Lease expiration Pool Client Name
------------ ------------------- --------------------- ------- -------------
10.0.1.222 00:99:88:77:66:55 2007/09/11 23:59:46 mydhcp Client_Laptop
Vyatta_RouterA>show dhcp statistics

Total DHCP requests for all pools: 11      
Total DHCP responses for all pools: 3      
         
pool   pool size # leased # avail
-----   -------- -------- ------
mydhcp   0 1 -1
Vyatta_RouterA>show route

0.0.0.0/0 [static(1)] > to 10.0.2.2 via eth0
10.0.2.0/24 [connected(0)] > to 10.0.2.1 via eth0
127.0.0.0/8 [connected(0)] > to 127.0.0.1 via lo
Vyatta_RouterB>show dhcp statisctics

dhcp server is not running
Vyatta_RouterB>show route

10.0.1.0/24 [connected(0)] > to 10.0.1.2 via eth0
10.0.2.0/24 [connected(0)] > to 10.0.2.2 via eth1
127.0.0.0/8 [connected(0)] > to 127.0.0.1 via lo

ANALYSE DES PAQUETS:

Wireshark (sur le poste de travail) et TCPdump (sur les routeurs Vyatta) sont utilisés pour capturer des paquets durant le processus de requête d'adresse IP.

Poste de travail (Desktop): (client DHCP)

La capture ci-dessus montre clairement les quatre étapes du processus des opérations DHCP.

- DHCP Discover:
- DHCP Offer:

- DHCP Request:

- DHCP Acknowledgement:
 
Le client diffuse (broadcast) pour trouver un serveur DHCP.
Le serveur envoie un message unicast au client avec une adresse IP.
Le client diffuse (broadcast) pour dire à d'éventuels autres serveurs DHCP qu'il a reçu une adresse IP.
Le serveur envoie un message unicast au client avec des paramètres optioniels comme la passerelle par défaut.
Il est intéressant de noter, au cas où vous souhaiteriez mettre en place des règles de firewall, que les paquets envoyés depuis un client utilisent le port source UDP 68 et le port destination UDP 67. Quand les paquets sont envoyés depuis le serveur vers le client, les ports source UDP 67 et destination UDP 68 sont utilisés.

Vyatta-RouterA: (serveur DHCP)

tcpdump -n port 67

IP 10.0.2.2.67 > 10.0.2.1.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 300
IP 10.0.2.1.67 > 10.0.1.2.67: BOOTP/DHCP, Reply, length 300
IP 10.0.2.2.67 > 10.0.2.1.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 329
IP 10.0.2.1.67 > 10.0.1.2.67: BOOTP/DHCP, Reply, length 300

Vyatta-RouterB: (DHCP relay)

tcpdump -n port 67

IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 300
IP 10.0.1.2.67 > 10.0.1.222.68: BOOTP/DHCP, Reply, length 300
IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 00:99:88:77:66:55, length 329
IP 10.0.1.2.67 > 10.0.1.222.68: BOOTP/DHCP, Reply, length 300


Haut de la page      Menu commandes show



2. ETUDE DE CAS CISCO

Cisco-RouterA#show ip route

Gateway of last resort is 10.0.2.2 to network 0.0.0.0

      10.0.0.0/24 is subnetted, 1 subnets
C         10.0.2.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.0.2.2
Cisco-RouterA#show ip dhcp binding

IP address
 
Client-ID/
Hardware address
Lease expiration
 
Type
 
10.0.1.200 0100.9988.7766.55 Mar 02 1993 12:45 AM Automatic
Cisco-RouterA#show ip dhcp server statistics

Memory usage 13393
Address pools 1
Database agents 0
Automatic bindings 1
Manual bindings 0
Expired bindings 0
Malformed messages 0
   
Message Received
BOOTREQUEST 0
DHCPDISCOVER 7
DHCPREQUEST 9
DHCPDECLINE 0
DHCPRELEASE 6
DHCPINFORM 0
   
Message Sent
BOOTREPLY 0
DHCPOFFER 7
DHCPACK 8
DHCPNAK 1
Cisco-RouterB#show ip route

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 2 subnets
C         10.0.2.0 is directly connected, FastEthernet0/1
C         10.0.1.0 is directly connected, FastEthernet0/0

ANALYSE DES PAQUETS:

Wireshark (sur le poste de travail) et TCPdump (sur les routeurs Vyatta) sont utilisés pour capturer des paquets durant le processus de requête d'adresse IP.

Poste de travail: (client DHCP)

La capture ci-dessus montre clairement les quatre étapes du processus des opérations DHCP.

- DHCP Discover:
- DHCP Offer:

- DHCP Request:

- DHCP Acknowledgement:
 
Le client diffuse (broadcast) pour trouver un serveur DHCP.
Le serveur envoie un message unicast au client avec une adresse IP.
Le client diffuse (broadcast) pour dire à d'éventuels autres serveurs DHCP qu'il a reçu une adresse IP.
Le serveur envoie un message unicast au client avec des paramètres optioniels comme la passerelle par défaut.
Il est intéressant de noter, au cas où vous souhaiteriez mettre en place des règles de firewall, que les paquets envoyés depuis un client utilisent le port source UDP 68 et le port destination UDP 67. Quand les paquets sont envoyés depuis le serveur vers le client, les ports source UDP 67 et destination UDP 68 sont utilisés.

Cisco-RouterA: (Serveur DHCP)

#debug ip dhcp server packet

DHCPD: DHCPDISCOVER received from client 0100.9988.7766.55 through relay 10.0.1.2.
DHCPD: Sending DHCPOFFER to client 0100.9988.7766.55 (10.0.1.200).
DHCPD: unicasting BOOTREPLY for client 0099.8877.6655 to relay 10.0.1.2.
DHCPD: DHCPREQUEST received from client 0100.9988.7766.55.
DHCPD: Sending DHCPACK to client 0100.9988.7766.55 (10.0.1.200).
DHCPD: unicasting BOOTREPLY for client 0099.8877.6655 to relay 10.0.1.2.


Les caractères "01" avant l'adresse MAC représentent le type de support Ethernet.

Cisco-RouterB: (Relai DHCP)

#debug ip dhcp server packet

DHCPD: setting giaddr to 10.0.1.2.
DHCPD: BOOTREQUEST from 0100.9988.7766.55 forwarded to 10.0.2.1.
DHCPD: forwarding BOOTREPLY to client 0099.8877.6655.
DHCPD: creating ARP entry (10.0.1.200, 0099.8877.6655).
DHCPD: unicasting BOOTREPLY to client 0099.8877.6655 (10.0.1.200).
DHCPD: Finding a relay for client 0100.9988.7766.55 on interface FastEthernet0/0.
DHCPD: setting giaddr to 10.0.1.2.
DHCPD: BOOTREQUEST from 0100.9988.7766.55 forwarded to 10.0.2.1.
DHCPD: forwarding BOOTREPLY to client 0099.8877.6655.
DHCPD: creating ARP entry (10.0.1.200, 0099.8877.6655).
DHCPD: unicasting BOOTREPLY to client 0099.8877.6655 (10.0.1.200).


Haut de la page      Menu commandes show