TOTAL
Since dec 2006
1'942'871 Visitors
4'218'042 Pages

Nov 2010 Stats
82'909 Visitors
146'476 Pages
196 countries
Full statistics



Help us translate
our tutorials!

JOIN the
OpenManiak Team.
OM TEAM
Director:
Blaise Carrera
Tutorials creation:
Blaise Carrera
Translaters:
Giovanni Fredducci
Angel Chraniotis
Moham. H. Karvan
Alexandro Silva
Blaise Carrera
Andrei Chertolyas
Sergiy Uvarov
Nickola Kolev
Łukasz Nowatkowski
Ivo Raisr
Catalin Bivolaru
Bogdan A. Costea
Kirill Simonov
Oliver Mucafir
JaeYoung Jeon
Seungyoon Lee
Jie Yu & Si Cheng
Tao Wei
YukiAlex
Fumihito Yoshida
Muhammad Takdir
Çağdaş Tülek
Auditors
Leslie Luthi
Joe Anderson
Jennifer Ockwell
Nigel Titley
Alison Rees
Sabrina Barbey
Webmaster:
Blaise Carrera
VYATTA - The Easy Tutorial - Cisco & Vyatta Commands

Vyatta Vyatta & Cisco commands
Last update: 26-12-2007


Tool
Install
Ergonomy
Forum



Details What is Vyatta?
Screenshots
Prerequisites
Tutorial Vyatta
Vyatta & Cisco Commands
Vyatta/Cisco/Quagga Comparison (Quagga section)
Case Study 1 - Static routes (VC 2.0)
Case Study 2 - OSPF simple (VC 2.0)
Case Study 3 - OSPF advanced (VC 2.0)
Case Study 4 - BGP (VC 3.0)
Case Study 5 - VRRP (VC 2.2)
Case Study 6 - NAT (VC 2.0)
Case Study 7 - DHCP (VC 2.2)
Case Study 8 - IPSec (VC 2.2)
Case Study 9 - Packages (VC 3.0)
Case Study 10 - Bridging (VC 3.0)
Case Study 11 - CDP VC 3.0




If you like our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!


Here is a non-exhaustive list of some Vyatta commands compared to Cisco commands.
Vyatta Version used: VC2

----- VYATTA OPERATIONAL MODE COMMANDS -----
 
ping
traceroute
show arp
show ip ospf neighbor
show ip ospf database
show ip route
show ip route | include
show ip interfaces
 
show ip bgp neighbors
show ip bgp
show clock
show ntp associations
show ip dhcp binding
show ip dhcp server statistics
show vrrp all
show ip nat translations
show ip nat statistics
ping
traceroute
show arp
show ospf4 neighbor
show ospf4 database
show route
show route | match ...
show interfaces ethernet ... physical
show interfaces ethernet ... statistics
show bgp peers
show bgp routes
show host date
show ntp associations
show dhcp lease
show dhcp statistics
show vrrp
show nat rules
show nat statistics

----- VYATTA CONFIGURATION MODE COMMANDS -----
 
SAVE
copy run tftp
N/A
save tftp://ip/name
save /mnt/floppy/config/config.boot
SHOW
show
show running-config
HELP
N/A
help
SET SERVICE
ip server http
line vty 0 4
  password
crypto key generate rsa
(only on some IOS versions)
set service http
set service telnet
 
set service ssh
 

ip dhcp pool
  network
  default-router
 
 
ip dhcp excluded-address
set service dhcp-server name
edit service dhcp-server name
  set start ... stop
  set default-router
  set network-mask
  set interface
  set exclude
SET SYSTEM
ip domain-name
ip default-gateway
hostname
username password
ntp server
ip name-server
terminal monitor
clock timezone
set system domain-name
set system gateway-address
set system host-name
set system login
set system ntp-server
set system name-server
set system syslog console
set system time-zone
logging
logging facility
logging trap
set system syslog host
set system syslog host ... facility
set system syslog host ... facility ... level
SET PROTOCOLS ...
INTERFACES
interface
  set description
  ip address
  duplex
  speed


  vrrp ... ip
  vrrp ... priority

edit interfaces
  set description
  set address ... prefix-length
  set duplex
  set speed

  set vrrp vrrp-group
  set vrrp ... virtual-address
  set vrrp priority
OSPF
 
router ospf 1
  router-id
  network ... area
  area ... stub|nssa
 
set protocols ospf4
edit protocols ospf4
  set router-id
  set area ... interface eth1 address
  set area ...area-type stub|nssa
STATIC
ip route

set protocols static route ...next-hop ...
BGP
 
router bgp
  bgp router-id
 
 
 
  neighbor ... remote-as

set protocols bgp
edit protocols bgp
  set bgp-ig
  set local-as
  set peer ...next-hop
  set peer ... local-ip
  set peer ... as
SNMP
snmp-server community ... ro|rw
snmp-server community ... ACL
snmp-server location
snmp-server contact
 
set protocols snmp community ... authorization ro|rw
set protocols snmp community ... client
set protocols snmp location
set protocols snmp contact





If you liked our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!